Bug 1193812 - Override puppet configuration on host level does not work if specified on host group
Summary: Override puppet configuration on host level does not work if specified on hos...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Shimon Shtein
QA Contact: Kedar Bidarkar
Russell Dickenson
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-02-18 09:54 UTC by Johan Swensson
Modified: 2019-06-13 21:25 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Issue: When you assign a host to a host group which has a Puppet Certificate Authority and PuppetMaster specified, and remove these value from the host, you will find that the values are reinstated when you click [Submit]. Workaround: Assign the host to a host group without a Puppet Certificate Authority and PuppetMaster specified.
Clone Of:
Environment:
Last Closed: 2015-10-15 18:19:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1911 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC
Foreman Issue Tracker 9591 None None None 2016-04-22 16:30:04 UTC

Description Johan Swensson 2015-02-18 09:54:05 UTC
Description of problem:
When editing a host it's not possible to override puppet ca and puppetmaster if the hostgroup specifies these.

Version-Release number of selected component (if applicable):
6.0.7

How reproducible:
Every time

Steps to Reproduce:
1. Create a host group that specifies puppet ca and puppetmaster
2. Assign a host to that host group
3. Edit the host and try remove puppet ca and puppetmaster, click submit
4. The Puppet CA and puppetmaster values are back

Actual results:
The values are still set.

Expected results:
It should be possible to override these values on host level.

Additional info:
Assigning the host to another host group that does not specify puppet ca or puppetmaster works as expected.

Comment 1 RHEL Product and Program Management 2015-02-18 20:06:32 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Shimon Shtein 2015-03-01 11:26:48 UTC
Created redmine issue http://projects.theforeman.org/issues/9591 from this bug

Comment 4 Bryan Kearney 2015-07-29 14:03:59 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9591 has been closed
-------------
Shimon Shtein
Applied in changeset commit:04cb74c06c05a06d993b3a1001e859519f2b15cf.

Comment 5 David O'Brien 2015-08-20 05:09:43 UTC
Does the content of "Additional Info" qualify as a workaround, or is there another approach I can add to the release note?

thanks

Comment 12 Kedar Bidarkar 2015-10-08 20:23:53 UTC
VERIFIED With sat6.1.3 - Satellite-6.1.0-RHEL-7-20151006.1

We can now remove puppet-ca and puppet-master.

Comment 14 errata-xmlrpc 2015-10-15 18:19:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.