Bug 119384 - Shutdown/restart failing to properly sync FS
Shutdown/restart failing to properly sync FS
Status: CLOSED DUPLICATE of bug 118880
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-29 18:07 EST by Benjmain Youngdahl
Modified: 2014-03-16 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjmain Youngdahl 2004-03-29 18:07:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Every shutdown or restart, even if I do absolutely nothing but
shutdown from the login screen, the system restarts with an unclean
filesystem, and is forced to repair.  Sometimes upon reboot, the
filesystem is corrupted to the point where I have to do a manual fsck.

Two strange messages are output from "mount" during shutdown:
...
Unmounting file systems:            [OK]
mount: could not open /proc/partitions, so UUID and LABEL conversion
could not be done.
mount: no such partition found
Halting system...
md: stopping all md devices.
md: md0 switched to read-only mode.
Synchronizing SCSI cache for disk sda:
Power down.


Every reboot, EXCEPT after a successful fsck, I see:
...
Checking root filesystem 
/ was not cleanly unmounted, check forced. 
/*** REBOOT LINUX****
/:  xxxxx/yyyyy yadayada files (etc.)   [ FAILED ]
*** An error occurred ...
(etc.  drops me to log on as root for maintence or hit control-d)


NOTES:
- Two partitions on single HD in system (sda), ("/" ext2, "/boot" ext3)
- No swap partition
- Fails same way whether shutdown or restart
- Dell precision workstation 410, SMP 400MHz x 2
- Same behavior using SMP and non-SMP kernel
- SCSI system with adaptec AIC7xxx controller
- System does NOT have this problem with Fedora Core 1; system had a
similar (perhaps identical) problem with FC2 Test1.
- No new partitions have been added since install


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot system
2.(Optionally: log on and do some work)
3.Do a shutdown or restart from the login screen
4.System will gripe about some problems in "mount" during shutdown scripts
5.Let system restart, or if you did a shutdown, power the system back on
6.System will now gripe that the "/" filesytem was not properly
unmounted, will do a check, and require a reboot.
7.System will now reboot fine, *but*, you're restarting at step 1
above... (ie. you'll have another corrupt filesystem after doing a
shutdown or restart.)

    

Additional info:

I've flagged this as "high" severity, as this has the potential to
lose data on the filesystem.
Comment 1 Bill Nottingham 2004-03-29 18:13:02 EST

*** This bug has been marked as a duplicate of 118880 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.