Bug 1193915 - [abrt] dnf: output.py:1730:historySummaryCmd:ValueError: need more than 0 values to unpack
Summary: [abrt] dnf: output.py:1730:historySummaryCmd:ValueError: need more than 0 val...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:fbdb48181197dc26dafe7109245...
Keywords:
: 1199177 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-18 14:47 UTC by Vít Ondruch
Modified: 2015-05-08 07:33 UTC (History)
10 users (show)

Fixed In Version: dnf-plugins-core-0.1.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 18:49:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.06 KB, text/plain)
2015-02-18 14:47 UTC, Vít Ondruch
no flags Details
File: environ (2.12 KB, text/plain)
2015-02-18 14:47 UTC, Vít Ondruch
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1193914 None None None Never

Internal Trackers: 1193914

Description Vít Ondruch 2015-02-18 14:47:15 UTC
Description of problem:
"$ sudo dnf history summary" does not work.

Version-Release number of selected component:
dnf-0.6.4-1.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python -OO /bin/dnf history summary
executable:     /bin/dnf
kernel:         3.18.3-201.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
output.py:1730:historySummaryCmd:ValueError: need more than 0 values to unpack

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1064, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/__init__.py", line 1221, in run
    ret = self.output.historySummaryCmd(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1730, in historySummaryCmd
    tids, printall = self._history_list_transactions(extcmds)
ValueError: need more than 0 values to unpack

Local variables in innermost frame:
self: <dnf.cli.output.Output object at 0x7faa94dc2c50>
extcmds: [u'summary']

Comment 1 Vít Ondruch 2015-02-18 14:47:19 UTC
Created attachment 993125 [details]
File: backtrace

Comment 2 Vít Ondruch 2015-02-18 14:47:20 UTC
Created attachment 993126 [details]
File: environ

Comment 3 Vít Ondruch 2015-02-18 14:49:07 UTC
BTW although this command is advertised using "dnf history help", it does not work nor it is mentioned in man page. May be it is entirely unsupported?

Comment 4 Radek Holy 2015-02-18 17:26:40 UTC
Thank you for the report.
Yes, since it is not documented, it is not supported. We should definitely fix at least the help message.
Are you interested in having this command (and turning this into an RFE)? Can you share the use case with us?

Comment 5 Vít Ondruch 2015-02-18 17:38:31 UTC
I have no idea what this command is good for. I was curious just due to bug 1193914

Comment 6 Radek Holy 2015-02-19 11:58:56 UTC
OK, so until someone with a proper use case for the command appears, I'd handle this bug just as that "dnf history summary" should not print a traceback and rather print just a "No such command" message.

Comment 7 Vít Ondruch 2015-02-19 12:00:17 UTC
Works with me.

Comment 8 Radek Holy 2015-03-06 09:32:19 UTC
*** Bug 1199177 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2015-03-31 18:17:57 UTC
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 11 lnie 2015-04-01 08:12:06 UTC
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 works

Comment 12 Fedora Update System 2015-04-02 01:44:12 UTC
Package hawkey-0.5.4-1.fc22, dnf-0.6.5-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.4-1.fc22 dnf-0.6.5-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5337/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2015-04-03 11:39:32 UTC
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 14 Fedora Update System 2015-04-06 18:49:22 UTC
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-04-16 09:05:10 UTC
dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21

Comment 16 Fedora Update System 2015-05-08 07:33:10 UTC
dnf-plugins-core-0.1.5-2.fc21, dnf-0.6.4-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.