Bug 1199177 - [abrt] dnf: output.py:1730:historySummaryCmd:ValueError: need more than 1 value to unpack
Summary: [abrt] dnf: output.py:1730:historySummaryCmd:ValueError: need more than 1 val...
Keywords:
Status: CLOSED DUPLICATE of bug 1193915
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:6741c75a43119fbd5e568149632...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-05 14:52 UTC by Lukas Slebodnik
Modified: 2015-03-07 00:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-06 09:32:18 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.07 KB, text/plain)
2015-03-05 14:53 UTC, Lukas Slebodnik
no flags Details
File: environ (2.28 KB, text/plain)
2015-03-05 14:53 UTC, Lukas Slebodnik
no flags Details

Description Lukas Slebodnik 2015-03-05 14:52:59 UTC
Description of problem:
I just called command
  dnf history summary 764

According to dnf output this command should work
[root@host ~]# dnf history help
Invalid history sub-command, use: list, info, summary, redo, undo, rollback, userinstalled.

But I cannot see itin man page
[user@host][~]$man dnf | grep history
       ยท history
       The  history  command allows the user to view what has happened in past
       dnf history [list]
              The  default  history  action  is  listing all known transaction
       dnf history info [<spec>...]
       dnf history redo <transaction-spec>
       dnf history rollback <transaction-spec>
       dnf history undo <transaction-spec>
       dnf history userinstalled

Version-Release number of selected component:
dnf-0.6.4-2.fc22

Additional info:
reporter:       libreport-2.4.0
cmdline:        /usr/bin/python -OO /bin/dnf history summary 764
dso_list:       python-dnf-0.6.4-2.fc22.noarch
executable:     /bin/dnf
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
output.py:1730:historySummaryCmd:ValueError: need more than 1 value to unpack

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1064, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/__init__.py", line 1221, in run
    ret = self.output.historySummaryCmd(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1730, in historySummaryCmd
    tids, printall = self._history_list_transactions(extcmds)
ValueError: need more than 1 value to unpack

Local variables in innermost frame:
self: <dnf.cli.output.Output object at 0x7f19197d46d0>
extcmds: [u'summary', u'764']

Comment 1 Lukas Slebodnik 2015-03-05 14:53:03 UTC
Created attachment 998417 [details]
File: backtrace

Comment 2 Lukas Slebodnik 2015-03-05 14:53:04 UTC
Created attachment 998418 [details]
File: environ

Comment 3 Radek Holy 2015-03-06 09:32:18 UTC
Hello, this is a duplicate of bug 1193915.

*** This bug has been marked as a duplicate of bug 1193915 ***


Note You need to log in before you can comment on or make changes to this bug.