Bug 1194238 - [Admin Portal] User <UNKNOWN>... appears after migration from RHEVH6 to RHEVH7 cluster
Summary: [Admin Portal] User <UNKNOWN>... appears after migration from RHEVH6 to RHEVH...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Shmuel Melamud
QA Contact: Israel Pinto
URL:
Whiteboard:
: 1197437 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-19 11:40 UTC by Jiri Belka
Modified: 2019-07-16 11:58 UTC (History)
9 users (show)

Fixed In Version: ovirt-3-6-0-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:58:09 UTC
oVirt Team: Virt


Attachments (Terms of Use)
engine.log (326.49 KB, application/x-gzip)
2015-02-19 11:40 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 38881 None None None Never

Description Jiri Belka 2015-02-19 11:40:47 UTC
Created attachment 993577 [details]
engine.log

Description of problem:

There appeared '<UNKNOWN>' in Events after I migrated a VM from a cluster consisting of RHEVH6 to a cluster consisting of RHEVH7. Seems odd...

# tail -f /var/log/ovirt-engine/engine.log | grep UNKNOWN
2015-02-19 12:30:14,440 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-38) [7da57427] Correlation ID: 7da57427, Call Stack: null, Custom Event ID: -1, Message: VM aaaaaaaaaaa configuration was updated by <UNKNOWN>.

2015-Feb-19, 12:17
User <UNKNOWN> got disconnected from VM aaaaaaaaaaa.
oVirt

2015-Feb-19, 12:17
User <UNKNOWN> is connected to VM aaaaaaaaaaa.
oVirt

2015-Feb-19, 12:17
User admin got disconnected from VM aaaaaaaaaaa.
oVirt

2015-Feb-19, 12:17
user admin initiated console session for VM aaaaaaaaaaa
658a046b
oVirt

2015-Feb-19, 12:15
Migration completed (VM: aaaaaaaaaaa, Source: dell-r210ii-13.rhev.lab.eng.brq.redhat.com, Destination: dell-r210ii-03.rhev.lab.eng.brq.redhat.com, Duration: 1 minute 20 seconds).
3f7c4f25
oVirt

2015-Feb-19, 12:15
VM aaaaaaaaaaa configuration was updated by <UNKNOWN>.
4f7621ca

2015-Feb-19, 12:14
Migration started (VM: aaaaaaaaaaa, Source: dell-r210ii-13.rhev.lab.eng.brq.redhat.com, Destination: dell-r210ii-03.rhev.lab.eng.brq.redhat.com, User: admin).
3f7c4f25
oVirt
	
2015-Feb-19, 12:11
Migration completed (VM: aaaaaaaaaaa, Source: dell-r210ii-03.rhev.lab.eng.brq.redhat.com, Destination: dell-r210ii-13.rhev.lab.eng.brq.redhat.com, Duration: 45 seconds).
3b93ae6a
oVirt

2015-Feb-19, 12:11
VM aaaaaaaaaaa configuration was updated by <UNKNOWN>.
22177f5
oVirt

2015-Feb-19, 12:11
User admin got disconnected from VM aaaaaaaaaaa.
oVirt

2015-Feb-19, 12:10
Migration started (VM: aaaaaaaaaaa, Source: dell-r210ii-03.rhev.lab.eng.brq.redhat.com, Destination: dell-r210ii-13.rhev.lab.eng.brq.redhat.com, User: admin).
3b93ae6a
oVirt

2015-Feb-19, 10:03
User admin is connected to VM aaaaaaaaaaa.
oVirt

2015-Feb-19, 10:03
user admin initiated console session for VM aaaaaaaaaaa
403c0bbc
oVirt

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.5.0-0.31.el6ev.noarch

How reproducible:
??

Steps to Reproduce:
1. have VM running on cluster with RHEVH6
2. live migrate to cluster with RHEVH7
3. watch Events

Actual results:
'admin' got replaced with <UNKNOWN> in Events

Expected results:
'admin'

Additional info:

Comment 1 Omer Frenkel 2015-03-02 08:14:14 UTC
Shmuel might be that your fix to the connect/disconnect msgs fix this as well?
https://gerrit.ovirt.org/#/c/38070/

Comment 2 Omer Frenkel 2015-03-10 09:40:08 UTC
*** Bug 1197437 has been marked as a duplicate of this bug. ***

Comment 3 Omer Frenkel 2015-03-22 15:16:54 UTC
messages for user connect/disconnect are solved by
https://gerrit.ovirt.org/#/c/38881/

if there are other messages with user unknown, please open a different bug for it, with steps to reproduce

Comment 4 Michael Burman 2015-06-10 11:54:43 UTC
Hi,

I still see such messages in my event log on - 3.6.0-0.0.master.20150528160348.gitdc324e4.el6

- But they are not persistent, sometimes i get user <UNKNOWN> 

2015-Jun-10, 14:42
User <UNKNOWN> is connected to VM SR_VM5_.

2015-Jun-10, 14:42
User admin@internal initiated console session for VM SR_VM5_

2015-Jun-10, 14:42
VM SR_VM5_ was started by admin@internal (Host: 10.1.64.53).

Like on the duplicated BZ 1197437 i opened ^^
user <UNKNOWN> is still appears when connecting to VM, 

- And sometimes name of user appears when connecting to VM:

2015-Jun-10, 14:51
User admin@internal is connected to VM SR_VM3_.

2015-Jun-10, 14:51
User admin@internal initiated console session for VM SR_VM3_

2015-Jun-10, 14:42
VM SR_VM5_ started on Host 10.1.64.53

Just letting you know, thanks.

Comment 5 Michael Burman 2015-06-10 11:59:33 UTC
Same behavior when disconnecting from VM -->

2015-Jun-10, 14:57
User admin@internal got disconnected from VM SR_VM3_.

2015-Jun-10, 14:57
User <UNKNOWN> got disconnected from VM SR_VM5_.

Comment 6 Michael Burman 2015-07-09 15:03:17 UTC
Hi, i see this as well:

event log :

"Migration failed (VM: Tamara_rhel_7_1, Source: camel-vdsa.qa.lab.tlv.redhat.com, Destination: <UNKNOWN>)."

When migrating to specific host and choosing Destination Host, but failing.(because network is not appears on Destination Host)

Engine knows the name of destination and <UNKNOWN> should be the name of destination Host, even if failing to migrate VM.

If it's not virt issue, please let me know and i will open new bug, thanks.

Comment 7 Israel Pinto 2015-12-14 13:39:03 UTC
Verify with:
RHEVM: 3.6.1.3-0.1.el6
3.5 Host:
vdsm-4.16.30-1.el6ev
libvirt-0.10.2-54.el6_7.2
3.6 Host:
vdsm-4.17.13-1.el7ev
libvirt-1.2.17-13.el7_2.2

scenario:
Set-up with 2 clusters: 3.6 cluster and 3.5 cluster
1 host on each cluster
Create VM and run it on cluster 3.5 host.
Migrate VM to host in 3.6 cluster.

Results:
VM migration to 3.6 cluster host. PASS

Comment 10 errata-xmlrpc 2016-03-09 20:58:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.