Bug 119454 - redhat-config-network fails to start
redhat-config-network fails to start
Status: CLOSED DUPLICATE of bug 117227
Product: Fedora
Classification: Fedora
Component: gnome-python2 (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
: 119452 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-03-30 12:28 EST by Casper Stevens
Modified: 2013-03-13 00:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-22 00:58:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Casper Stevens 2004-03-30 12:28:03 EST
Description of problem:
redhat-network-config and many other redhat-xxxxxx-config applications
fail to open. Most have the bonobo import error. Services dialog fails
to start also.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.start => system settings => network 


Actual results:
Error window opens or nothing at all

Expected results:
Apps should start up.

Additional info:

Component: redhat-config-network
Version: 1.3.10
Summary: TBd9d48f1f NewInterfaceDialog.py:27:?:ImportError: could not
import bonobo.ui
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 138, in main
    import netconfpkg.gui.GUI_functions
line 36, in ?
  File "<string>", line 1, in ?
line 27, in ?
ImportError: could not import bonobo.ui

Local variables in innermost frame:
signal: <module 'signal' (built-in)>
__builtins__: {'help': Type help() for interactive help, or
help(object) for help about object., 'vars': <built-in function vars>,
'pow': <built-in function pow>, 'RuntimeError': <class
exceptions.RuntimeError at 0x84808a4>, 'float': <type 'float'>,
'StopIteration': <class exceptions.StopIteration at 0x847f634>,
'globals': <built-in function globals>, 'divmod': <built-in function
divmod>, 'unicode': <type 'unicode'>, 'apply': <built-in function
apply>, 'isinstance': <built-in function isinstance>, 'open': <type
'file'>, 'ArithmeticError': <class exceptions.ArithmeticError at
0x84825ec>, 'quit': 'Use Ctrl-D (i.e. EOF) to exit.', 'UnicodeError':
<class exceptions.UnicodeError at 0x8482e14>, 'zip': <built-in
function zip>, 'LookupError': <class exceptions.LookupError at
0x848035c>, 'super': <type 'super'>, 'AttributeError': <class
exceptions.AttributeError at 0x847a9c4>, 'hex': <built-in function
hex>, 'long': <type 'long'>, 'ReferenceError': <class
exceptions.ReferenceError at 0x8482fec>, 'NameError': <class
exceptions.NameError at 0x8480ae4>, 'ImportError': <class
exceptions.ImportError at 0x847fe2c>, 'chr': <built-in function chr>,
'complex': <type 'complex'>, 'dict': <type 'dict'>, '__import__':
<built-in function __import__>, 'input': <built-in function input>,
'type': <type 'type'>, 'oct': <built-in function oct>, 'SystemExit':
<class exceptions.SystemExit at 0x847fbc4>, 'Exception': <class
exceptions.Exception at 0x847f3b4>, 'StandardError': <class
exceptions.StandardError at 0x847f7ec>, 'tuple': <type 'tuple'>,
'repr': <built-in function repr>, 'SystemError': <class
exceptions.SystemError at 0x848304c>, 'IOError': <class
exceptions.IOError at 0x8480204>, 'IndexError': <class
exceptions.IndexError at 0x8482294>, 'hasattr': <built-in function
hasattr>, 'delattr': <built-in function delattr>, 'False': 0,
'RuntimeWarning': <class exceptions.RuntimeWarning at 0x8483dc4>,
'setattr': <built-in function setattr>, 'raw_input': <built-in
function raw_input>, 'list': <type 'list'>, 'SyntaxWarning': <class
exceptions.SyntaxWarning at 0x8483a4c>, 'iter': <built-in function
iter>, '__doc__': "Built-in functions, exceptions, and other
objects.\n\nNoteworthy: None is the `nil' object; Ellipsis represents
`...' in slices.", 'compile': <built-in function compile>, 'reload':
<built-in function reload>, 'Warning': <class exceptions.Warning at
0x84834f4>, 'str': <type 'str'>, 'property': <type 'property'>,
'round': <built-in function round>, 'dir': <built-in function dir>,
'cmp': <built-in function cmp>, 'MemoryError': <class
exceptions.MemoryError at 0x848337c>, 'hash': <built-in function
hash>, 'int': <type 'int'>, 'xrange': <built-in function xrange>,
'reduce': <built-in function reduce>, 'KeyError': <class
exceptions.KeyError at 0x8482424>, 'coerce': <built-in function
coerce>, 'intern': <built-in function intern>, 'exit': 'Use Ctrl-D
(i.e. EOF) to exit.', 'issubclass': <built-in function issubclass>,
'file': <type 'file'>, 'EnvironmentError': <class
exceptions.EnvironmentError at 0x8480124>, 'unichr': <built-in
function unichr>, 'id': <built-in function id>, 'locals': <built-in
function locals>, 'slice': <built-in function slice>,
'DeprecationWarning': <class exceptions.DeprecationWarning at
0x848389c>, 'min': <built-in function min>, 'FloatingPointError':
<class exceptions.FloatingPointError at 0x8482b04>, 'execfile':
<built-in function execfile>, 'OverflowWarning': <class
exceptions.OverflowWarning at 0x8483c04>, 'getattr': <built-in
function getattr>, 'abs': <built-in function abs>, 'bool': <built-in
function bool>, 'True': 1, 'ValueError': <class exceptions.ValueError
at 0x8482b64>, 'NotImplemented': NotImplemented, 'map': <built-in
function map>, 'None': None, 'EOFError': <class exceptions.EOFError at
0x8480714>, 'buffer': <built-in function buffer>, 'max': <built-in
function max>, 'object': <type 'object'>, 'len': <built-in function
len>, 'TabError': <class exceptions.TabError at 0x8481b2c>,
'callable': <built-in function callable>, 'credits': Thanks to CWI,
CNRI, BeOpen.com, Digital Creations and a cast of thousands
for supporting Python development.  See www.python.org for more
information., 'SyntaxError': <class exceptions.SyntaxError at
0x847ab2c>, 'OSError': <class exceptions.OSError at 0x8480564>,
'eval': <built-in function eval>, '__name__': '__builtin__', 'ord':
<built-in function ord>, '__debug__': 1, 'IndentationError': <class
exceptions.IndentationError at 0x8481acc>, '_': <bound method
i18n.gettext of <rhpl.translate.i18n instance at 0x84f085c>>,
'AssertionError': <class exceptions.AssertionError at 0x8481df4>,
'TypeError': <class exceptions.TypeError at 0x847f84c>, 'copyright':
Copyright (c) 2001, 2002 Python Software Foundation.
All Rights Reserved.

Copyright (c) 2000 BeOpen.com.
All Rights Reserved.

Copyright (c) 1995-2001 Corporation for National Research Initiatives.
All Rights Reserved.

Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam.
All Rights Reserved., 'license': See
http://www.python.org/2.2/license.html, 'classmethod': <type
'classmethod'>, 'KeyboardInterrupt': <class
exceptions.KeyboardInterrupt at 0x847fdcc>, 'UserWarning': <class
exceptions.UserWarning at 0x84836bc>, 'ZeroDivisionError': <class
exceptions.ZeroDivisionError at 0x848295c>, 'UnboundLocalError':
<class exceptions.UnboundLocalError at 0x847a834>, 'filter': <built-in
function filter>, 'range': <built-in function range>, 'staticmethod':
<type 'staticmethod'>, 'NotImplementedError': <class
exceptions.NotImplementedError at 0x8480a84>, 'Ellipsis': Ellipsis,
'OverflowError': <class exceptions.OverflowError at 0x8482794>}
__name__: netconfpkg.gui.NewInterfaceDialog
gtk: <module 'gtk' from
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
__doc__: None
Comment 1 Bill Nottingham 2004-03-30 17:14:03 EST
*** Bug 119452 has been marked as a duplicate of this bug. ***
Comment 2 Steven Pritchard 2004-04-12 15:14:55 EDT
I was able to reproduce this bug running redhat-config-printer-gui 
on a system upgraded from Red Hat 7.2 to Fedora Core 1 with apt.  I 
assumed there must be a missing dependency somewhere, so I tried 
doing "import bonobo.ui" directly from the python interpreter.  That 
gave me "ImportError: could not import gnome.canvas", so I installed 
gnome-python2-canvas, and now redhat-config-printer-gui works fine. 
Apparently gnome-python2-bonobo is missing a dependency on 
Comment 3 Harald Hoyer 2004-04-13 08:03:58 EDT
reassigning to gnome-python2
Comment 4 John Thacker 2006-04-22 00:58:18 EDT

*** This bug has been marked as a duplicate of 117227 ***

Note You need to log in before you can comment on or make changes to this bug.