Bug 119484 - package dependency problem
package dependency problem
Status: CLOSED DUPLICATE of bug 119679
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 16:09 EST by Glenn Powers
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Glenn Powers 2004-03-30 16:09:33 EST
Description of problem:

There was a package dependency problem.  The message was:

Unresolvable chain of dependencies:
dvgrab  1.5-1                            requires libdv.so.2
gimp-print-plugin  4.2.6-9               requires libgimp-1.3.so.26
gimp-print-plugin  4.2.6-9               requires libgimpbase-1.3.so.26
gimp-print-plugin  4.2.6-9               requires libgimpcolor-1.3.so.26
gimp-print-plugin  4.2.6-9               requires libgimpmath-1.3.so.26
gimp-print-plugin  4.2.6-9               requires libgimpmodule-1.3.so.26
gimp-print-plugin  4.2.6-9               requires libgimpui-1.3.so.26
gimp-print-plugin  4.2.6-9               requires libgimpwidgets-1.3.so.26
gstreamer-plugins  0.8.0-1               requires libdv.so.2
gtkam-gimp  0.1.10-2.1                   requires libgimp-1.3.so.26
gtkam-gimp  0.1.10-2.1                   requires libgimpbase-1.3.so.26
gtkam-gimp  0.1.10-2.1                   requires libgimpcolor-1.3.so.26
gtkam-gimp  0.1.10-2.1                   requires libgimpmath-1.3.so.26
gtkam-gimp  0.1.10-2.1                   requires libgimpui-1.3.so.26
gtkam-gimp  0.1.10-2.1                   requires libgimpwidgets-1.3.so.26
iiimf-le-canna  11.4-32                  requires libcanna.so.1.2
kinput2-canna-wnn6  v3.1-17              requires libcanna16.so.1.2
nvi-m17n-canna  1.79-20011024.18         requires libcanna.so.1.2
pwlib  1.6.3-2                           requires libdv.so.2
xemacs  21.4.15-3                        requires libRKC.so.1.2
xemacs  21.4.15-3                        requires libcanna.so.1.2
xsane-gimp  0.92-7                       requires libgimp-1.3.so.26
xsane-gimp  0.92-7                       requires libgimpbase-1.3.so.26
xsane-gimp  0.92-7                       requires libgimpcolor-1.3.so.26
xsane-gimp  0.92-7                       requires libgimpmath-1.3.so.26
xsane-gimp  0.92-7                       requires libgimpui-1.3.so.26
xsane-gimp  0.92-7                       requires libgimpwidgets-1.3.so.26

Please modify your package selections and try again.


Version-Release number of selected component (if applicable):

Fedora Core 2 Test 2

How reproducible:

Always

Steps to Reproduce:
1. Install Core 2 Test 2, Select "Everything" for Packages
2. Run up2date
3.
  
Actual results:

Error.

Expected results:

Updated system.

Additional info:
Comment 1 Adrian Likins 2004-03-30 18:33:55 EST
what command line was being used?
Comment 2 Richard Schaal 2004-04-01 12:03:11 EST
I am seeing similar results - command line is just "up2date &" run as
root.

The problem is the up2date doesn't recognize that the "dependency" is
already installed.  

Here's the complaint from up2date ( run 4/1/04 ) 
There was a package dependency problem.  The message was:

Unresolvable chain of dependencies:
XFree86-4.3.0-45.0.1                     requires XFree86-libs =
4.3.0-45.0.1
XFree86-4.3.0-45.0.1                     requires XFree86-xfs =
4.3.0-45.0.1
XFree86-devel-4.3.0-45.0.1               requires XFree86-libs =
4.3.0-45.0.1
XFree86-twm-4.3.0-45.0.1                 requires XFree86-libs =
4.3.0-45.0.1
balsa  2.0.16-3                          requires libgal-2.0.so.6
balsa  2.0.16-3                          requires libgal-a11y-2.0.so.6
balsa  2.0.16-3                          requires libgtkhtml-3.0.so.4
dvgrab  1.5-1                            requires libdv.so.2
ethereal  0.10.2-1.1                     requires libpcap.so.0.8.1
ethereal-gnome  0.10.2-1.1               requires libpcap.so.0.8.1
iiimf-le-canna  11.4-32                  requires libcanna.so.1.2
pwlib  1.6.3-2                           requires libdv.so.2
redhat-lsb  1.3-1                        requires /usr/bin/kill
xemacs  21.4.15-3                        requires libRKC.so.1.2
xemacs  21.4.15-3                        requires libcanna.so.1.2

Please modify your package selections and try again.

- When I run rpm -q -a , I can see the dependencies are already installed.

- I won't bore you with adding the list of packages - since it is the
outcome of installing "EVERYTHING" from the FC2- test1 ISOs.
Comment 3 Adrian Likins 2004-04-07 16:25:55 EDT

*** This bug has been marked as a duplicate of 119679 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.