Bug 119512 - [reiserfs] No inittab file found
[reiserfs] No inittab file found
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 19:25 EST by Kevin Tambascio
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 09:47:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda installer logfile/syslog and ls of etc after install (17.83 KB, text/plain)
2004-04-05 12:27 EDT, Dave Johnson
no flags Details
anaconda installer logfile/syslog and ls of etc after install (17.83 KB, application/octet-stream)
2004-04-05 12:28 EDT, Dave Johnson
no flags Details

  None (edit)
Description Kevin Tambascio 2004-03-30 19:25:18 EST
Description of problem:
I installed Fedora Core 2 Test 2 on my Dell PII-450 machine. 
Installation goes fine.  When I reboot, I get this error:

INIT: version 2.85 booting
INIT: No inittab file found

Version-Release number of selected component (if applicable):


How reproducible:
I tried to re-install overtop of the initial install, but the same
problem occurs under reboot.

Steps to Reproduce:
1.  Begin the install.  pass the lines "linux reiserfs" to the boot
screen.
2.  Proceed in the install.  
3.  Reboot.  See the No inittab file found message.
  
Actual results:
inittab is not found by the init process.

Expected results:
inittab should be there.

Additional info:
I have found this using "linux resiserfs" as the boot params during
the install, because I wanted reiserfs support.  I don't know if this
error is caused because of asking for reiserfs.  During bootup, it
appears that it recognizes the reiserfs as 3.6, so I don't think its
an issue of a missing kernel module.

I plan to re-install clean on the same box, without specifying
reiserfs, to see if that is the problem.  If that clears it up, still
seems as there is an issue.  I have also booted disabling selinux, and
had the same error, so I'm fairly certain it is not an selinux issue.
Comment 1 Kevin Tambascio 2004-03-30 19:27:01 EST
Since I cannot actually get into any runlevel, I cannot attach output
from dmesg.  Let me know if there is anything other info that I can
give you.

I forgot to mention, my partitions are like this (IDE drive):

/dev/hda1 = swap
/dev/hda2 = /boot = ext3
/dev/hda3 = / = reiserfs
Comment 2 Bill Nottingham 2004-03-30 21:42:48 EST
This sounds like either an issue with files not getting installed
right on reiserfs, or the known issue where SELinux will not work with
reiserfs (bug 119486).
Comment 3 Kevin Tambascio 2004-03-30 23:41:40 EST
Bill/Arjan, 
 
I did try to boot with selinux=disabled, but I still see the same issue.   
 
I chose the third form of SELinux (can't remember what that's called, not 
disabled, and not active.  The mode where it just logs the events). 
 
-Kevin 
Comment 4 Vadim Gritsenko 2004-03-31 20:59:44 EST
I can confirm this - and I also used "linux reiserfs" option.
Comment 5 Vadim Gritsenko 2004-03-31 21:29:42 EST
Once booted from CD, manually mounted root partition:
  mkdir /tmp/screwit
  mount /dev/hda5 /tmp/screwit

And manually installing package:
  rpm -i --root /tmp/screwit --noscripts --notriggers init*

Seems worked ok (except some errors about pre-scripts) and created
/etc/inittab file. After reboot, kernel paniced during hardware detection.
Comment 6 Dave Johnson 2004-04-05 11:56:17 EDT
FYI -- We have seen the same problem (no /etc/inittab) on the following:

Dell 6300 (4 procs, 2.5G memory)
Perc2 megaraid (466)
without SELinux enabled
Reiserfs on /, resierfs within LVM on /tmp, swap, /usr, /var.
Qlogic 2200 HBA (no storage attached for install)

Incidentally, on a fresh install, that has SElinux enabled, we get a
DOS on the text screen.  Can not login or anything.   
Comment 7 Dave Johnson 2004-04-05 12:27:29 EDT
Created attachment 99116 [details]
anaconda installer logfile/syslog and ls of etc after install
Comment 8 Dave Johnson 2004-04-05 12:28:17 EDT
Created attachment 99117 [details]
anaconda installer logfile/syslog and ls of etc after install

augh resending as binary...
Comment 9 Dave Johnson 2004-04-05 12:37:27 EDT
Looking at the attachment for the install.log it looks like it can not
update some /etc files, is it looking in the right location?... 

Some clues:
...
Installing rpm-4.3-0.22.i386.
warning: user rpm does not exist - using root
warning: group rpm does not exist - using root
...
Installing initscripts-7.48-1.i386.
groupadd: cannot rewrite group file
error: %pre(initscripts-7.48-1) scriptlet failed, exit status 10
error:   install: %pre scriptlet failed (2), skipping initscripts-7.48-1
...
Installing slocate-2.7-7.i386.
groupadd: cannot rewrite group file
error: %pre(slocate-2.7-7) scriptlet failed, exit status 10
error:   install: %pre scriptlet failed (2), skipping slocate-2.7-7
Comment 10 Dave Johnson 2004-04-08 15:41:19 EDT
(1) Installing system from cdrom with args:  
    linux resierfs selinux=0 causes it to install fine

(2) reboot from cd:  linux rescue

(3) copy/tar over /dev/mapper device entries to /sysimage 

The machine should boot OK now to test FC2t2.
Comment 11 Svetlio Bajlekov 2004-04-11 19:38:43 EDT
The initscripts and slocate packages invariably fail to install for 
me with the above-mentioned errors. On two different computers 
(noname Athlon/SiS and Inspiron 5150), on both ext3 and reiserfs 
(both with and without "reiserfs" boot parameter). Also with SElinux 
set to either "Active" or "Disabled"(however without "selinux=0" 
bootparam). Obviously not all of the above combinations, but several. 
Additionally, errors about not being to update group and passwd 
files, as mentioned above.

Workaround is to boot with init=/bin/bash after install, install 
initscripts manually and fix group and passwd files.
Comment 12 Dan Hollis 2004-04-14 14:27:14 EDT
instructions in comment #10 do not work.

had to install initscripts manually after install from 'linux rescue'
mode.

Note You need to log in before you can comment on or make changes to this bug.