Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1195137 - there is no katello-configure manual page and other issues in backup section
Summary: there is no katello-configure manual page and other issues in backup section
Keywords:
Status: CLOSED DUPLICATE of bug 1172418
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Docs User Guide
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: Unspecified
Assignee: David O'Brien
QA Contact: Athene Chan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-23 08:20 UTC by Jan Hutař
Modified: 2018-08-30 21:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-24 04:12:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2015-02-23 08:20:12 UTC
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/User_Guide/sect-Disaster_Recovery.html


Section Number and Name: 
Procedure 16.2. Red Hat Satellite Backup Procedure


Describe the issue:
There is:

PostgreSQL Databases Backup
Check the names for Red Hat Satellite PostgreSQL databases. Default database names are foremanschema and candlepin. Find all default values in the katello-configure manual page, or in the /usr/share/katello/install/default-answer-file. If the Red Hat Satellite instance is not using the default names, check the katello-configure.conf, which stores all options provided to the katello-configure command, and look for db_name. 


Suggestions for improvement: 
There is no katello-configure manual page:

# man katello-configure
No manual entry for katello-configure


Additional information: 
I have tried this on Satellite-6.0.4-RHEL-6-20140908.0-Satellite-x86_64

Comment 1 Jan Hutař 2015-02-23 08:21:41 UTC
Also this file is missing:

# grep db_name /etc/katello/katello-configure.conf
grep: /etc/katello/katello-configure.conf: No such file or directory

Comment 2 Jan Hutař 2015-02-23 08:28:09 UTC
Also looks like default DB name is "foreman" and not "foremanschema".

Comment 3 RHEL Program Management 2015-02-23 17:13:37 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 David O'Brien 2015-02-24 04:12:06 UTC

*** This bug has been marked as a duplicate of bug 1172418 ***


Note You need to log in before you can comment on or make changes to this bug.