Bug 119515 - No such device /dev/dsp
Summary: No such device /dev/dsp
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Keywords:
: 121550 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-31 00:37 UTC by Christopher Stone
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version: 1.2.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 18:46:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Stone 2004-03-31 00:37:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040225 Firefox/0.8

Description of problem:
system-config-soundcard gives the following error when run:

amixer:  Mixer attach default error:  No such device
amixer:  Mixer attach default error:  No such device
sox:  Can't open output file '/dev/dsp':  No such device

/dev/dsp looks like this:

crw-------  1  chris root  14,  3 Feb 23 13:02  /dev/dsp



Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.7-3

How reproducible:
Always

Steps to Reproduce:
1.  Run system-config-soundcard
2.  Play test sound

    

Actual Results:  See description.

Expected Results:  Should play test sound.

Additional info:

Comment 1 Christopher Stone 2004-03-31 00:56:52 UTC
running:  modprobe snd-ens1371 enables sound for me but shouldn't this
be automatically loaded on boot?

Comment 2 Captain 2004-04-12 07:04:13 UTC
"same here" on FC2test2 (plain CD install - no updates)

# lspci
[...]
00:12.0 Multimedia Audio Controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)

The card is detected successfully, but fails to play the test-sound:
[root@mag root]# system-config-soundcard
sox: Can't open output file '/dev/dsp': No such device
amixer: Mixer attach default error: No such device
amixer: Mixer attach default error: No such device
-9

After adding the driver manually with "modprobe snd-ens1371" it worked.
For a permanent solution I added this to modprobe.conf:

# ALSA portion
alias char-major-116* snd
alias snd-card-0 snd-ens1371

# OSS/Free portion
alias char-major-14* soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

install snd-card-0 /sbin/modprobe --ignore-install snd-card-0 && {
/usr/sbin/alsactl restore >/dev/null 2>&1 || :; }
remove snd-card-0 { /usr/sbin/alsactl store >/dev/null 2>&1 || :; };
/sbin/modprobe -r --ignore-remove

install sound-slot-0 /sbin/modprobe --ignore-install sound-slot-0 && {
/bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S
>>/dev/null 2>&1 || :; }; /sbin/modprobe -r --ignore-remove

BTW, the soundcard was not present during FC2test2 install - I added
it later...



Comment 3 Bill Nottingham 2004-04-16 03:57:11 UTC
Please try 1.3.8-1 or later.

Comment 4 Captain 2004-04-19 20:22:59 UTC
Bill, sorry for not getting back to you earlier...

Do you mean system-config-soundcard-1.3.8-1 ?

I currently have 1.2.8-1 and up2date tells me there is no more recent
version... anyway, I just removed my manually added entries from
modprobe.conf, rebooted, tried system-config-soundcard and I got:
sox: Can't open output file '/dev/dsp': No such device
amixer: Mixer attach default error: No such device
amixer: Mixer attach default error: No such device

After manually attaching the driver with "modprobe snd-ens1371" it
works...
Please let me know if you need any further details...

Comment 5 Christopher Stone 2004-04-29 00:04:28 UTC
I looked for 1.3.8-1 in the rawhide ftp and the latest version there
is 1.2.8-1.  Where can we find 1.3.8-1?  I just tested 1.2.8-1 under
FC2 Test3 and it still doesn't work.  However, after manually running
"modprobe snd-ens1371" the sound works.

Comment 6 Brent Fox 2004-05-03 14:51:55 UTC
Christopher:  I think notting made a typo.  1.2.8-1 is the latest version.

notting:  It looks like the driver isn't getting loaded prior to
system-config-soundcard running.  Is this a kudzu problem?

Comment 7 Bill Nottingham 2004-05-03 18:45:31 UTC
It should be loaded on demand.

Comment 8 Alan Lehman 2004-06-03 02:16:26 UTC
I had the same experience with i810.
'modprobe snd-intel8x0' fixes it.

Comment 9 Brent Fox 2004-06-17 16:15:36 UTC
*** Bug 121550 has been marked as a duplicate of this bug. ***

Comment 10 Alexey Neyman 2004-07-23 05:23:01 UTC
I have a similar problem: KDE complains about /dev/dsp (no such 
device), however, after the KDE's sound system is restarted (Control 
Center -> Audio, turn off, apply, turn on, apply), sound works ok. 
 
 

Comment 11 Bastien Nocera 2004-09-19 13:16:39 UTC
Fix in 1.2.9 with this commit:

* Wed Jul 21 2004 Bastien Nocera <bnocera@redhat.com>
<snip>
- use aplay to play sounds on 2.6 kernels


Comment 12 Christopher Stone 2004-09-23 19:19:43 UTC
Now, when I start KDE, I get nothing but static.  If I try to run
system-config-soundcard I get the following error:

 system-config-soundcard
Traceback (most recent call last):
  File
"/usr/share/system-config-soundcard/system-config-soundcard.py", line
46, in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 87, in
__init__
    self.device, self.module, self.maker, self.model =
self.soundcardBackend.getData(card)
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line
98, in getData
    maker, model = string.split(description, "|")
ValueError: unpack list of wrong size

Comment 13 Christopher Stone 2004-09-23 19:23:32 UTC
Actually, I do get sound after running alsamixer, but there is still a
lot of static present.

Comment 14 Bill Nottingham 2004-09-23 19:52:40 UTC
That crash is fixed in current rawhide. Static is a driver issue.

Comment 15 Christopher Stone 2004-09-26 16:13:46 UTC
The static isn't a driver issue because it works fine in GNOME.  Only
in KDE does the static start up.

Comment 16 Bill Nottingham 2004-09-26 18:46:23 UTC
Please open a new bug against arts, then.


Note You need to log in before you can comment on or make changes to this bug.