Bug 1195661 - lock files cannot be created for non logged users
Summary: lock files cannot be created for non logged users
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 22
Hardware: Unspecified Unspecified
high
unspecified
Target Milestone: ---
Assignee: Michal Luscon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1204368 (view as bug list)
Depends On:
Blocks: 1156485
TreeView+ depends on / blocked
 
Reported: 2015-02-24 10:04 UTC by Jakub Filak
Modified: 2016-12-01 00:48 UTC (History)
8 users (show)

Fixed In Version: dnf-plugins-core-0.1.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 18:49:24 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jakub Filak 2015-02-24 10:04:39 UTC
Description of problem:
The ProcessLock class tries to create lock files in /run/user/[uid], but the directory exists only if the user is logged in and regular users do not have sufficient rights to create a run directory for them. This behaviour causes me problems when I run my script downloading debuginfo packages into a directory owned by user abrt, because the script must be suided, so /run/user/173 (uid of abrt is 173 does not exist).

I've opened the following pull request:
https://github.com/rpm-software-management/dnf/pull/227

Version-Release number of selected component (if applicable):
dnf-0.6.4-1.fc22.noarch

How reproducible:
Always

Steps to Reproduce:
1.use dnf API in a suided binary 


Actual results:
[Errno 13] Permission denied: '/run/user/173'

Expected results:
No such an error.

Additional info:
# ls -al /usr/libexec/abrt-action-install-debuginfo-to-abrt-cache 
-rwsr-sr-x. 1 abrt abrt 11280 Feb 24 08:39 /usr/libexec/abrt-action-install-debuginfo-to-abrt-cache

Comment 1 Jakub Filak 2015-03-21 14:03:00 UTC
*** Bug 1204368 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2015-03-31 18:18:01 UTC
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 3 Fedora Update System 2015-04-02 01:44:17 UTC
Package hawkey-0.5.4-1.fc22, dnf-0.6.5-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.4-1.fc22 dnf-0.6.5-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5337/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2015-04-03 11:39:34 UTC
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 5 Fedora Update System 2015-04-06 18:49:24 UTC
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2015-04-16 09:05:05 UTC
dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21

Comment 7 Fedora Update System 2015-05-08 07:33:03 UTC
dnf-plugins-core-0.1.5-2.fc21, dnf-0.6.4-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.