This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 119576 - kernel hangs at boot during aic7xxx initialization
kernel hangs at boot during aic7xxx initialization
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FC2Target FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-03-31 10:29 EST by Thomas J. Baker
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 11:09:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2004-03-31 10:29:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Galeon/1.3.13

Description of problem:
After a clean install of fc2t2 and an upgrade to the latest rawhide, a
reboot finds the kernel hanging during the aic7xxx initialization with
kernel 298. Rebooting to the older kernel-smp-2.6.3-2.1.253.2.1 kernel
works fine. 

Version-Release number of selected component (if applicable):
kernel-smp-2.6.4-1.298

How reproducible:
Always

Steps to Reproduce:
1. try to boot kernel kernel-smp-2.6.4-1.298
2.
3.
    

Actual Results:  system hangs

Expected Results:  system boots

Additional info:
Comment 1 Thomas J. Baker 2004-03-31 10:35:09 EST
For grins I tried booting the uniprocessor kernel and it booted fine
so it seems SMP related.
Comment 2 Thomas J. Baker 2004-03-31 11:21:53 EST
kernel-smp-2.6.4-1.300 hangs in the same way.
Comment 3 Bill Nottingham 2004-04-01 00:44:50 EST
lspci output?
Comment 4 Thomas J. Baker 2004-04-01 08:07:09 EST
[root@katratzi tjb]# /sbin/lspci -vv
00:00.0 Host bridge: Intel Corp. 82840 840 (Carmel) Chipset Host
Bridge (Hub A) (rev 02)
        Subsystem: Dell Computer Corporation: Unknown device 0096
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort+ >SERR- <PERR+
        Latency: 0
        Region 0: Memory at d0000000 (32-bit, prefetchable)
        Capabilities: [a0] AGP version 2.0
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64-
HTrans- 64bit- FW+ AGP3- Rate=x1,x2,x4
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit-
FW- Rate=<none>
 
00:01.0 PCI bridge: Intel Corp. 82840 840 (Carmel) Chipset AGP Bridge
(rev 02) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        Memory behind bridge: fc000000-fdffffff
        Prefetchable memory behind bridge: e0000000-e7ffffff
        BridgeCtl: Parity- SERR+ NoISA+ VGA+ MAbort- >Reset- FastB2B-
 
00:1e.0 PCI bridge: Intel Corp. 82801AA PCI Bridge (rev 02) (prog-if
00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Bus: primary=00, secondary=02, subordinate=03, sec-latency=64
        I/O behind bridge: 0000d000-0000efff
        Memory behind bridge: f8000000-fbffffff
        BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
 
00:1f.0 ISA bridge: Intel Corp. 82801AA ISA Bridge (LPC) (rev 02)
        Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
 
00:1f.1 IDE interface: Intel Corp. 82801AA IDE (rev 02) (prog-if 80
[Master])
        Subsystem: Intel Corp. 82801AA IDE
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Region 4: I/O ports at ffa0 [size=16]
 
00:1f.2 USB Controller: Intel Corp. 82801AA USB (rev 02) (prog-if 00
[UHCI])
        Subsystem: Intel Corp. 82801AA USB
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin D routed to IRQ 185
        Region 4: I/O ports at ff80 [size=32]
 
00:1f.3 SMBus: Intel Corp. 82801AA SMBus (rev 02)
        Subsystem: Intel Corp. 82801AA SMBus
        Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin B routed to IRQ 177
        Region 4: I/O ports at ccd0 [size=16]
 
01:00.0 VGA compatible controller: nVidia Corporation NV15 [GeForce2
GTS/Pro] (rev a4) (prog-if 00 [VGA])
        Subsystem: nVidia Corporation: Unknown device 002e
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (1250ns min, 250ns max)
        Interrupt: pin A routed to IRQ 169
        Region 0: Memory at fc000000 (32-bit, non-prefetchable)
[size=c0000000]
        Region 1: Memory at e0000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at 00010000 [disabled]
        Capabilities: [60] Power Management version 1
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [44] AGP version 2.0
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA- ITACoh- GART64-
HTrans- 64bit- FW+ AGP3- Rate=x1,x2,x4
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit-
FW- Rate=<none>
 
02:04.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado]
(rev 78)
        Subsystem: Dell Computer Corporation: Unknown device 0096
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (2500ns min, 2500ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 169
        Region 0: I/O ports at dc80 [size=f9000000]
        Region 1: Memory at f8fffc00 (32-bit, non-prefetchable) [size=128]
        Expansion ROM at 00020000 [disabled]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-
 
02:06.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24
[CrystalClear SoundFusion Audio Accelerator] (rev 01)
        Subsystem: Dell Computer Corporation: Unknown device 0096
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (1000ns min, 6000ns max)
        Interrupt: pin A routed to IRQ 193
        Region 0: Memory at f8ffe000 (32-bit, non-prefetchable)
        Region 1: Memory at f8e00000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk+ DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 
02:0e.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev
03) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64, Cache Line Size 08
        Bus: primary=02, secondary=03, subordinate=03, sec-latency=64
        I/O behind bridge: 0000e000-0000efff
        Memory behind bridge: fa000000-fbffffff
        Expansion ROM at 0000e000 [disabled] [size=4K]
        BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
        Capabilities: [dc] Power Management version 1
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=220mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
                Bridge: PM- B3+
 
03:0a.0 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
        Subsystem: Dell Computer Corporation: Unknown device 0096
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (10000ns min, 6250ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 193
        BIST result: 00
        Region 0: I/O ports at ec00 [disabled] [size=fb000000]
        Region 1: Memory at fafff000 (64-bit, non-prefetchable) [size=4K]
        Expansion ROM at 00020000 [disabled]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 
03:0a.1 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
        Subsystem: Dell Computer Corporation: Unknown device 0096
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (10000ns min, 6250ns max), Cache Line Size 08
        Interrupt: pin B routed to IRQ 185
        BIST result: 00
        Region 0: I/O ports at e800 [disabled] [size=fb000000]
        Region 1: Memory at faffe000 (64-bit, non-prefetchable) [size=4K]
        Expansion ROM at 00020000 [disabled]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 
[root@katratzi tjb]#
Comment 5 Thomas J. Baker 2004-04-07 09:42:19 EDT
With the 305 smp kernel after about 1/2 hour of nothing, I get this on
the console (hand typed):

scsi0:0:0:0: Attempting to queue an ABORT message
CDB: 0x12 0x0 0x0 0x0 0x24 0x0
scis0:0:0:0: Command already completed

It does this slowly for each device number (0-15), goes on to the
second bus, does the same thing, eventually boots and panics due to no
root disk.
Comment 6 Thomas J. Baker 2004-04-08 11:50:41 EDT
The 308 kernel boots and works fine. The changelog doesn't give any
indication that anything related has changed but it works now.
Comment 7 Robert Haas 2004-04-20 12:15:16 EDT
This may be related to bug 117584.  The aic7xxx seems to have been
intermittently problematic for a long time.
Comment 8 Alan Cox 2004-05-03 10:58:56 EDT
440GX bug is different. Not sure what this one is, but it looks like
it is having interrupt problems. Does booting with "acpi=off" help ?
Comment 9 Lars Damerow 2004-05-03 17:18:04 EDT
I was seeing similar symptoms while trying to kickstart Fedora Core 2
test 3 on an SMP aic7xxx machine; adding acpi=off to the kernel options
fixed the problem for me.

cheers,
lars
Comment 10 Dave Jones 2004-12-07 00:49:01 EST
ok with current errata kernel ?
Comment 11 Thomas J. Baker 2004-12-07 06:38:20 EST
This has been fine for me for a long time right up through the latest rawhide
kernel.

Note You need to log in before you can comment on or make changes to this bug.