Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1195956 - [abrt] dnf: lock.py:85:_try_read_lock:ValueError: invalid literal for int() with base 10: ''
Summary: [abrt] dnf: lock.py:85:_try_read_lock:ValueError: invalid literal for int() w...
Keywords:
Status: CLOSED DUPLICATE of bug 1194685
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3898dcf72a9339b799463c95feb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-24 21:53 UTC by Ashish Bhurtel
Modified: 2015-03-02 02:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-25 09:08:42 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.26 KB, text/plain)
2015-02-24 21:53 UTC, Ashish Bhurtel
no flags Details
File: environ (2.18 KB, text/plain)
2015-02-24 21:53 UTC, Ashish Bhurtel
no flags Details

Description Ashish Bhurtel 2015-02-24 21:53:37 UTC
Version-Release number of selected component:
dnf-0.6.4-1.fc22

Additional info:
reporter:       libreport-2.4.0
cmdline:        /usr/bin/python -OO /bin/dnf upgrade
executable:     /bin/dnf
kernel:         3.20.0-0.rc0.git10.1.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
lock.py:85:_try_read_lock:ValueError: invalid literal for int() with base 10: ''

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1063, in run
    self._process_demands()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 785, in _process_demands
    load_available_repos=lar)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 227, in fill_sack
    with lock:
  File "/usr/lib/python2.7/site-packages/dnf/lock.py", line 106, in __enter__
    pid = self._try_read_lock()
  File "/usr/lib/python2.7/site-packages/dnf/lock.py", line 85, in _try_read_lock
    return int(f.readline())
ValueError: invalid literal for int() with base 10: ''

Local variables in innermost frame:
self: <dnf.lock.ProcessLock object at 0x7fb73b532dd0>
f: <closed file u'/var/cache/dnf/x86_64/22/x86_64/22/metadata_lock.pid', mode 'r' at 0x7fb73b771c90>

Comment 1 Ashish Bhurtel 2015-02-24 21:53:39 UTC
Created attachment 994880 [details]
File: backtrace

Comment 2 Ashish Bhurtel 2015-02-24 21:53:40 UTC
Created attachment 994881 [details]
File: environ

Comment 3 Michal Luscon 2015-02-25 09:08:42 UTC

*** This bug has been marked as a duplicate of bug 1194685 ***


Note You need to log in before you can comment on or make changes to this bug.