Bug 1194685 - CACHEDIR_SUFFIX appended twice to cachedir when using dnf CLI.
CACHEDIR_SUFFIX appended twice to cachedir when using dnf CLI.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
:
: 1195432 1195956 1197547 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-20 09:34 EST by Hristo Venev
Modified: 2015-05-08 03:32 EDT (History)
10 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 14:49:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hristo Venev 2015-02-20 09:34:21 EST
Once in dnf.base.Base._setup_default_conf() and once in dnf.cli.cli.Cli._configure_cachedir(). This was broken in 9b6de97c71f5b32929e9f23bd1dc7c6cb33dd67d.

I think CACHEDIR_SUFFIX should be appended to cachedir only once after releasever and possibly arch (bug 1190854) have been set.
Comment 1 Radek Holy 2015-02-24 04:14:32 EST
*** Bug 1195432 has been marked as a duplicate of this bug. ***
Comment 2 Michal Luscon 2015-02-25 04:08:42 EST
*** Bug 1195956 has been marked as a duplicate of this bug. ***
Comment 3 Michal Luscon 2015-03-02 09:23:55 EST
*** Bug 1197547 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2015-03-31 14:18:05 EDT
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
Comment 5 Fedora Update System 2015-04-01 21:44:21 EDT
Package hawkey-0.5.4-1.fc22, dnf-0.6.5-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.4-1.fc22 dnf-0.6.5-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5337/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2015-04-03 07:39:37 EDT
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
Comment 7 Fedora Update System 2015-04-06 14:49:29 EDT
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-04-16 05:05:00 EDT
dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21
Comment 9 Fedora Update System 2015-05-08 03:32:59 EDT
dnf-plugins-core-0.1.5-2.fc21, dnf-0.6.4-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.