Bug 1196099 - Instance type: missing VM fields while using InstanceCreator user role.
Summary: Instance type: missing VM fields while using InstanceCreator user role.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.1
Assignee: Tomas Jelinek
QA Contact: Nisim Simsolo
URL:
Whiteboard: virt
Depends On: 1180105 1198609
Blocks: 1193058
TreeView+ depends on / blocked
 
Reported: 2015-02-25 10:09 UTC by Tomas Jelinek
Modified: 2015-04-29 06:38 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1180105
Environment:
Last Closed: 2015-04-29 06:38:25 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 36827 0 None None None Never
oVirt gerrit 36830 0 None None None Never

Description Tomas Jelinek 2015-02-25 10:09:13 UTC
+++ This bug was initially created as a clone of Bug #1180105 +++

Description of problem:
According to instance types design table (http://www.ovirt.org/index.php?title=Features/Instance_Types#Design), fields marked with "Y" under basic user column, should be present for creating/editing when login to user portal using user with InstanceCreator role.
the missing fields are OS dropbox and cloud-init/Sysprep.

Version-Release number of selected component (if applicable):
rhevm-3.5.0-0.27.el6ev.noarch
libvirt-1.1.1-29.el7_0.3.x86_64
sanlock-3.1.0-2.el7.x86_64
vdsm-4.16.8.1-4.el7ev.x86_64
qemu-kvm-rhev-1.5.3-60.el7_0.11.x86_64


How reproducible:
Consistently

Steps to Reproduce:
1. Create new user with InstanceCreator user role.
2. Login to user portal using the new user created.
3. Edit/create VM and verify fields marked with "Y" according to instance type design table (http://www.ovirt.org/index.php?title=Features/Instance_Types#Design) are present.

Actual results:
There are two missing fields: OS and Cloud-Init/Sysprep.

Expected results:
OS and Cloud-Init/Sysprep should be present in edit/create VM options.

Additional info:
Snapshot attached.

--- Additional comment from Nisim Simsolo on 2015-01-08 06:31:19 EST ---



--- Additional comment from Michal Skrivanek on 2015-01-10 07:03:51 EST ---

OS comes from the image, not instance type.
cloud-init/sysprep should be excluded, so I guess just update the wiki

--- Additional comment from Tomas Jelinek on 2015-01-12 03:37:37 EST ---

OS does come from the image, but we do not provide images so far, so currently it comes from the template. But since the user is not forced to pick a non-blank template, this field should be shown and editable for the user.

@Michal - considering this, do you think we can fix the OS in 3.5 (.1)?

--- Additional comment from Michal Skrivanek on 2015-01-12 10:26:48 EST ---

sure

--- Additional comment from Eyal Edri on 2015-02-25 03:45:24 EST ---

3.5.1 is already full with bugs (over 80), and since none of these bugs were added as urgent for 3.5.1 release in the tracker bug, moving to 3.5.2

Comment 1 Nisim Simsolo 2015-03-04 13:58:35 UTC
Bug cannot be verified using rhevm-3.5.1-0.1.el6ev due to bug: https://bugzilla.redhat.com/show_bug.cgi?id=1198609

Comment 2 Michal Skrivanek 2015-03-09 08:35:14 UTC
(In reply to Nisim Simsolo from comment #1)
> Bug cannot be verified using rhevm-3.5.1-0.1.el6ev due to bug:
> https://bugzilla.redhat.com/show_bug.cgi?id=1198609

then create a role in DB directly. This shouldn't block you...

Comment 3 Nisim Simsolo 2015-03-19 08:46:55 UTC
Verified using rhevm-3.5.1-0.1.el6ev.
Also verified that cloud-init or sysprep is now marked with "N" under basic user column in instance types design table (http://www.ovirt.org/index.php?title=Features/Instance_Types#Design)

Comment 4 Eyal Edri 2015-04-29 06:38:25 UTC
RHEV 3.5.1 was GAd.


Note You need to log in before you can comment on or make changes to this bug.