This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 119646 - KDE's desktop icons appear on Gnome
KDE's desktop icons appear on Gnome
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC2Target FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-03-31 21:49 EST by Eugenia Loli-Queru
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 02:54:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eugenia Loli-Queru 2004-03-31 21:49:47 EST
From Bugzilla Helper:

Description of problem:
I used Gnome and then XFce and then I went to KDE. After I got bored 
with its bloat, I relogged in on Gnome.
Oh-the-horror.
All KDE's desktop icons are now appearing on Gnome! I get a "CD-ROM" 
desktop icon, a floppy one, a duplicated "eugenia home" entry etc etc
It seems that if you visit KDE And then you go back to Gnome, it 
overwrites stuff somewhere and so Nautilus loads KDE's desktop icons 
in addition to gnome's.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. go to gnome, go to xfce, go to kde, go back to gnome
2.
3.
    

Additional info:
Comment 1 Alexander Larsson 2004-04-06 10:36:42 EDT

*** This bug has been marked as a duplicate of 117135 ***
Comment 2 Gene Czarcinski 2004-04-17 09:31:49 EDT
This is not a dup of 117135 (double trash) but that I have kde's home,
CD/DVD and floppy icons on gnome's desktop and nautilus 2.6.0-4 does
not fix this problem.

I even ge tthis for a newly defined user that does login to gnome,
logout, login to kde, logout, login to gnome and double icons.
Comment 3 Alexander Larsson 2004-04-20 09:54:20 EDT
I dunno what to do with the other desktop files. I can't just hardcode
in Nautilus the names that kde could possibly use to create desktop
files on the Desktop.
Comment 4 Eugenia Loli-Queru 2004-04-20 14:00:07 EDT
Why do these desktop files are showing on Gnome anyway?

What if I delete them from my Gnome desktop? Will they be deleted 
from the KDE desktop as well? And if login again to KDE will they 
appear again on Gnome?

If the answer is yes to these questions (sorry, I have nuked my 
Fedora partition so I can't test it anymore), then freedekstop.org --
or whatever is behind this interoperability mulfunction-- has a 
fundamental flaw. And instead of hardcoding stuff to hack around 
them, I suggest you fix the flaw in its root (by shouting at Havoc if 
you have to ;-).
Comment 5 Alexander Larsson 2004-05-04 13:11:57 EDT
The desktop files are auto-created by kde, so will probably be
recreated on login to kde (as they where the first time you logged in
to kde).

Shouting at havoc will not solve this. Freedesktop has no way to force
people to interoperate, nor has it ever tried to standardize use of
~/Desktop. freedesktop is a good place for someone to start a
discussion of how to solve this problem though, since you might reach
most of the parties involved.
Comment 6 Eugenia Loli-Queru 2004-05-04 17:58:52 EDT
Erm, yeah, but for now, this remains a bug IMHO. If 
freekdesktop.org's turn hasn't come yet to "discuss" the situation, 
something has to be done at this point for your distro. I mean, 
Mandrake 10 didn't have this behavior, so I am sure there is a way 
around it (even if you have to go around hacks, which of course I 
don't really like either, but point is, some kind of action needs to 
be taken).

Maybe you would also like to start a discussion about it on 
freedesktop.org's list in the meantime and propose a "standard" which 
will fix the problem in the long term? Being the Nautilus leader, 
seems appropriate to me.
Comment 7 Havoc Pennington 2004-11-03 12:57:44 EST
The fix here has to be upstream. We should resolve this as UPSTREAM.

IMO the correct fix is for KDE not to create those files, they could
use virtual files instead as nautilus does. But in any case it's not
something we're going to hack into our packages.

Note You need to log in before you can comment on or make changes to this bug.