Bug 1196658 - Discovered host should not be rebooted when user gets validation error on edit host form
Summary: Discovered host should not be rebooted when user gets validation error on edi...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin (Show other bugs)
(Show other bugs)
Version: 6.1.0
Hardware: Unspecified Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 1193977
TreeView+ depends on / blocked
 
Reported: 2015-02-26 13:15 UTC by Sachin Ghai
Modified: 2017-02-23 20:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 16:05:22 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 10195 None None None 2016-04-22 16:02 UTC

Description Sachin Ghai 2015-02-26 13:15:32 UTC
Description of problem:
I discovered a host and and click on provision from webUI.. and I got some validation error on host form..

the discovered host rebooted even I got some validation error on host form.

Version-Release number of selected component (if applicable):
sat6.1 beta snap4
Satellite-6.1.0-RHEL-6-20150224.0

How reproducible:
always

Steps to Reproduce:
1. pxe boot a host
2. Go to hosts-> discovered_host
3. click on provision
4. and don't specify name so that UI raised some validation error

Actual results:
discovered host rebooted

Expected results:
discovered host shouldn't be rebooted

Additional info:

Comment 2 Bryan Kearney 2015-04-17 20:13:15 UTC
Created redmine issue http://projects.theforeman.org/issues/10195 from this bug

Comment 6 Bryan Kearney 2015-07-19 10:03:36 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10195 has been closed
-------------
Anonymous
Applied in changeset commit:foreman_discovery|442b37854eaffa04893e7b50eb47c1d58ff47222.

Comment 9 Bryan Kearney 2015-07-21 12:17:49 UTC
merged.

Comment 11 Sachin Ghai 2015-07-24 07:49:39 UTC
Verified with sat6.1.1 GA snap14 on rhel66.

I discovered a host and while trying to provision it, I created couple of managed interfaces without mac addresses and without identifier and submit the edit_host form. 

UI raises error but host doesn't get rebooted on error. Later I fixed all the errors and submitted the edit-host form successfully and this time host auto re-booted and provisioning started automatically.

Thanks for the fix.

Comment 12 Bryan Kearney 2015-08-12 16:05:22 UTC
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.

Comment 13 Lukas Zapletal 2015-11-16 10:00:11 UTC
*** Bug 1278639 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.