Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1196658 - Discovered host should not be rebooted when user gets validation error on edit host form
Discovered host should not be rebooted when user gets validation error on edi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: Unused
Assigned To: Lukas Zapletal
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1193977
  Show dependency treegraph
 
Reported: 2015-02-26 08:15 EST by Sachin Ghai
Modified: 2017-02-23 15:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 12:05:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 10195 None None None 2016-04-22 12:02 EDT

  None (edit)
Description Sachin Ghai 2015-02-26 08:15:32 EST
Description of problem:
I discovered a host and and click on provision from webUI.. and I got some validation error on host form..

the discovered host rebooted even I got some validation error on host form.

Version-Release number of selected component (if applicable):
sat6.1 beta snap4
Satellite-6.1.0-RHEL-6-20150224.0

How reproducible:
always

Steps to Reproduce:
1. pxe boot a host
2. Go to hosts-> discovered_host
3. click on provision
4. and don't specify name so that UI raised some validation error

Actual results:
discovered host rebooted

Expected results:
discovered host shouldn't be rebooted

Additional info:
Comment 2 Bryan Kearney 2015-04-17 16:13:15 EDT
Created redmine issue http://projects.theforeman.org/issues/10195 from this bug
Comment 6 Bryan Kearney 2015-07-19 06:03:36 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/10195 has been closed
-------------
Anonymous
Applied in changeset commit:foreman_discovery|442b37854eaffa04893e7b50eb47c1d58ff47222.
Comment 9 Bryan Kearney 2015-07-21 08:17:49 EDT
merged.
Comment 11 Sachin Ghai 2015-07-24 03:49:39 EDT
Verified with sat6.1.1 GA snap14 on rhel66.

I discovered a host and while trying to provision it, I created couple of managed interfaces without mac addresses and without identifier and submit the edit_host form. 

UI raises error but host doesn't get rebooted on error. Later I fixed all the errors and submitted the edit-host form successfully and this time host auto re-booted and provisioning started automatically.

Thanks for the fix.
Comment 12 Bryan Kearney 2015-08-12 12:05:22 EDT
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.
Comment 13 Lukas Zapletal 2015-11-16 05:00:11 EST
*** Bug 1278639 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.