Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
When provisioning a system with discovery I can fill out the needed information (hostgroup etc.) but if any part of the form is missing satellite will reboot the discovered machine but does not let the user continue to finish provisioning.
How reproducible:
Always
Steps to Reproduce:
1. boot a new host in discovery mode
2. click provision host in satellite
3. fill out the information. If root password is missing or any form data causes an error (network conflict) and you click submit the form will error out and stay on the "provision host page"
4. Satellite reboots the host even though provisioning is not complete
5. Correct form data and click submit again
6. Satellite will now hang on the "rebooting host" step because the host was already rebooted in step 3
Actual results:
At that point there is no way to continue provisioning. You have to cancel the provisioning, delete the discovered host and reboot the host into discovery mode again. This also usually leaves orphened information in dhcpd.leases file and sometimes in dns. Those two sources will need to be manually deleted before provisioning the host again.
Ok I have reproduced. We've fixed similar bug already in 6.1.1 (not 6.1.4 that was a typo), but there is still one.
WORKAROUND: Fix the cause of the orchestration error that triggers reboot.
Its not reproducible with Satellite 6.2 snap1. Please see the screenshot for verification where host is not rebooted even though error messages are populated on form submission.