This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1278639 - Orchestration error does not prevent reboot of a discovered host
Orchestration error does not prevent reboot of a discovered host
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin (Show other bugs)
6.1.3
All Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Katello QA List
: Reopened, Triaged
Depends On:
Blocks: 1287901
  Show dependency treegraph
 
Reported: 2015-11-05 23:24 EST by Jacob Hunt
Modified: 2016-03-03 05:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-03 05:01:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
on error, discovered host doesn't reboot. (66.32 KB, image/png)
2016-03-03 04:52 EST, Sachin Ghai
no flags Details

  None (edit)
Description Jacob Hunt 2015-11-05 23:24:10 EST
Description of problem:

When provisioning a system with discovery I can fill out the needed information (hostgroup etc.) but if any part of the form is missing satellite will reboot the discovered machine but does not let the user continue to finish provisioning.


How reproducible:

Always

Steps to Reproduce:

1. boot a new host in discovery mode
2. click provision host in satellite
3. fill out the information. If root password is missing or any form data causes an error (network conflict) and you click submit the form will error out and stay on the "provision host page"
4. Satellite reboots the host even though provisioning is not complete
5. Correct form data and click submit again
6. Satellite will now hang on the "rebooting host" step because the host was already rebooted in step 3

Actual results:

At that point there is no way to continue provisioning. You have to cancel the  provisioning, delete the discovered host and reboot the host into discovery mode again. This also usually leaves orphened information in dhcpd.leases file and sometimes in dns. Those two sources will need to be manually deleted before provisioning the host again.
Comment 2 Lukas Zapletal 2015-11-16 05:00:11 EST
This reboot error will be fixed in 6.1.4.

*** This bug has been marked as a duplicate of bug 1196658 ***
Comment 3 Lukas Zapletal 2015-11-16 07:13:13 EST
Ok I have reproduced. We've fixed similar bug already in 6.1.1 (not 6.1.4 that was a typo), but there is still one.

WORKAROUND: Fix the cause of the orchestration error that triggers reboot.
Comment 4 Lukas Zapletal 2016-03-03 04:34:42 EST
Can't reproduce on Satellite 6.2 build, sending to QE.
Comment 5 Sachin Ghai 2016-03-03 04:51:19 EST
Its not reproducible with Satellite 6.2 snap1. Please see the screenshot for verification where host is not rebooted even though error messages are populated on form submission.
Comment 6 Sachin Ghai 2016-03-03 04:52 EST
Created attachment 1132706 [details]
on error, discovered host doesn't reboot.
Comment 7 Sachin Ghai 2016-03-03 05:01:45 EST
Closing this bz, Please feel free to re-open or file a new if you come across this issue again.

Note You need to log in before you can comment on or make changes to this bug.