Bug 1197218 - Add missing dependencies into freeipa packages
Summary: Add missing dependencies into freeipa packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: IPA Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1197838 (view as bug list)
Depends On:
Blocks: F22AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-02-27 20:36 UTC by Lukas Slebodnik
Modified: 2015-03-16 15:28 UTC (History)
11 users (show)

Fixed In Version: authconfig-6.2.10-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 18:22:48 UTC


Attachments (Terms of Use)

Description Lukas Slebodnik 2015-02-27 20:36:19 UTC
Description of problem:

ipa-client install does not work due to missing dependency. It is caused by
BZ1014594 "sssd: Support Python 3". sssd >= 1.12.4-2.fc22 does not directly depend on python2 and thus does not install python2 bindings.

freeipa should explicitly requires python and does not depend on packaging of other packages. 

Version-Release number of selected component (if applicable):
sh# rpm -q sssd freeipa-client
sssd-1.12.4-2.fc22.x86_64
freeipa-client-4.1.3-1.fc22.x86_64

How reproducible:
deterministic

Steps to Reproduce:
1. dnf install -y freeipa-client 
2. ipa-client-install

Actual results:
sh# ipa-client-install 
There was a problem importing one of the required Python modules. The
error was:

    No module named SSSDConfig

Expected results:
ipa-client-install works as expected.

Additional info:
sh# rpm -q --requires sssd | grep python
python3-sssdconfig = 1.12.4-2.fc22

Comment 1 Lukas Slebodnik 2015-02-27 20:39:28 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4929

Comment 2 Lukas Slebodnik 2015-03-02 17:34:44 UTC
*** Bug 1197838 has been marked as a duplicate of this bug. ***

Comment 3 Scott Poore 2015-03-02 17:47:04 UTC
This is the Fedora Release Alpha Criteria that I think applies to this bug:

https://fedoraproject.org/wiki/Fedora_22_Alpha_Release_Criteria#Remote_authentication

Comment 4 Petr Schindler 2015-03-02 17:56:08 UTC
Discussed at today's blocker review meeting [1].

This bug was accepted as Alpha Blocker - This bug is a clear violation of the Alpha criterion: "It must be possible to join the system to a FreeIPA or Active Directory domain at install time and post-install, and the system must respect the identity, authentication and access control configuration provided by the domain."

http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-02/

Comment 5 Martin Kosek 2015-03-03 11:35:14 UTC
Petr, can you please get the patches that Lukas kindly provided reviewed and added to our Fedora 22 build?

Comment 6 Fedora Update System 2015-03-04 19:49:02 UTC
authconfig-6.2.10-3.fc22,freeipa-4.1.3-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/authconfig-6.2.10-3.fc22,freeipa-4.1.3-2.fc22

Comment 7 Fedora Update System 2015-03-05 18:22:48 UTC
authconfig-6.2.10-3.fc22, freeipa-4.1.3-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.