Bug 119783 - rpm --test returns "error: can't create transaction lock" when run without root privs
Summary: rpm --test returns "error: can't create transaction lock" when run without ro...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 120496 (view as bug list)
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-04-02 05:59 UTC by Gregory Leblanc
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 23:49:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gregory Leblanc 2004-04-02 05:59:47 UTC
Description of problem:
Running 'rpm --test -Uvh somepackage.rpm' as a non-root user now
returns "error: can't create transaction lock".  Prior versions did
not return an error.

Version-Release number of selected component (if applicable):
rpm-4.3-0.22

How reproducible:
Always

Comment 1 Bill Nottingham 2004-04-06 03:38:16 UTC
Any SELinux error messages?

Comment 2 Gregory Leblanc 2004-04-06 05:35:09 UTC
In the logs, or on the console?  The console reports only the
transaction lock error.

From chatting with Jeff about this a bit, it seems that --test does
what it has always done, and it "works" doing that, despite this
error.  I haven't verified that personally, though it's on my list. 
If I understood correctly, he also said this was due to some internal
changes in RPM and not due to something else (though I did not ask
about SELinux).  

Comment 3 Miloslav Trmac 2004-04-06 17:05:22 UTC
This happens even with SELinux completely disabled 
(In particular, I have tried rpm -ev --test boost).

Comment 4 Jeff Johnson 2004-04-07 23:49:52 UTC
Fixed in rpm-4.3.1-0.2 when built.

Comment 5 Jeff Johnson 2004-04-09 14:01:11 UTC
*** Bug 120496 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.