Bug 120496 - can't "rpm -Uvh --test" as non-superuser
can't "rpm -Uvh --test" as non-superuser
Status: CLOSED DUPLICATE of bug 119783
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 09:29 EDT by Jonathan Kamens
Modified: 2007-04-18 13:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2004-04-09 09:29:43 EDT
I upgraded to rpm-4.3.1-0.1 yesterday.  Now when I run "rpm -Uvh
--test *.rpm" as myself rather than root, I get "error: can't create
transaction lock".  This is new, and in my opinion incorrect,
behavior.  I shouldn't need a transaction lock to perform a read-only
operation, and testing an upgrade should always be read-only.
Comment 1 Jeff Johnson 2004-04-09 10:01:08 EDT

*** This bug has been marked as a duplicate of 119783 ***
Comment 2 Ngo Than 2005-11-03 06:27:14 EST
*** Bug 171958 has been marked as a duplicate of this bug. ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:02:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.