Bug 119784 - Epiphany uses OpenOffice to view source
Epiphany uses OpenOffice to view source
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks: FC2Blocker FC3Target
  Show dependency treegraph
 
Reported: 2004-04-02 01:01 EST by Michael A. Peters
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 14:59:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael A. Peters 2004-04-02 01:01:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
After using yum to update my FC2T2 install, viewing source in Epiphany
launches OpenOffice.org to open the file - which results in not a text
description of the source, but in a formatted document.

Before running yum to update the OS - it acted correctly, and used a
different app (not sure which one) to view the source, as a syntax
highlighted text file.

My system was updated via yum at aproximately 8 PM PST on 4/1

Mozilla still has the correct behaviour for viewing source.

Version-Release number of selected component (if applicable):
epiphany-1.1.12-0

How reproducible:
Always

Steps to Reproduce:
1. Launch Epiphany
2. choose "Page Source" from view menu
    

Actual Results:  OpenOffice.org word processor starts

Expected Results:  text display similar to the current behaviour when
this is tried in Mozilla

Additional info:
Comment 1 François Kooman 2004-05-04 17:16:53 EDT
Possible solution: 

Preferences -> Preferred Applications -> Text Editor -> Select an
Editor : gedit
Comment 2 Michael A. Peters 2004-05-04 17:53:11 EDT
It should imho behave the same way that mozilla currently does.
But I will try that.
Comment 3 Mikel Ward 2004-05-05 06:42:27 EDT
I don't see this problem with Fedora 2 Test 3, which also uses
ephiphany 1.1.12 (for me it opens the page in GNOME Edit).

Is it possible you have associated OpenOffice.org Writer with
HTML (text/html) files?  You could confirm this with
Menu->Preferences->File types and programs->Documents->WWW->HTML page
Comment 4 Michael A. Peters 2004-05-06 12:51:05 EDT
I haven't tried in Test 3 - but I hate OO.o (I think it is bloated and
buggy - I much prefer the AbiWord/Gnumeric combo) and didn't assign
OO.o to anything.

Changing the default text editor to gedit did work, there wasn't one
set before, so apparently when there is not a default gnome text
editor set, for whatever reason Epiphany (but not Mozilla) would use
OO.o for the viewing of the source.

I'm currently running test2 updated to test3 - I have the test3 iso's,
I will have to fresh install and see what it does. I think to properly
test I'll have to fresh install on a single partition (so there are no
settings brought over from my home directory) - I'll do that, either
tonight or next week (tomorrow I go out of town)
Comment 5 Colin Charles 2004-09-16 06:29:42 EDT
Did this get fixed in FC2? It's definitely not a bug in FC3(well, rawhide)
Comment 6 Bryan W Clark 2004-10-04 14:59:54 EDT
I believe this is an issue of the new MIME system and not having a
decent default set.  bug 131643 is where this should have been fixed.
 I'm gonna close this now since it shouldn't be appearing anymore.

Note You need to log in before you can comment on or make changes to this bug.