Bug 1197940 - kde-l10n conflicts
Summary: kde-l10n conflicts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-l10n
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
: 1218370 (view as bug list)
Depends On:
Blocks: F22FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-03-03 02:18 UTC by Rex Dieter
Modified: 2015-05-13 01:46 UTC (History)
14 users (show)

Fixed In Version: kde-l10n-14.12.3-6.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-13 01:46:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Rex Dieter 2015-03-03 02:18:37 UTC
Jam spin is failing to compose due to apparent kde-l10n conflicts:

Transaction couldn't start:
file /usr/share/locale/sr@ijekavian/LC_MESSAGES/baloo_file.mo conflicts between attempted installs of kde-l10n-sr-14.12.1-1.fc22.noarch and kf5-baloo-file-5.6.0-3.fc22.x86_64
file /usr/share/locale/sr@ijekavian/LC_MESSAGES/baloosearch.mo conflicts between attempted installs of kde-l10n-sr-14.12.1-1.fc22.noarch and kf5-baloo-5.6.0-3.fc22.x86_64
file /usr/share/locale/sr@ijekavian/LC_MESSAGES/balooshow.mo conflicts between attempted installs of kde-l10n-sr-14.12.1-1.fc22.noarch and kf5-baloo-5.6.0-3.fc22.x86_64
file /usr/share/locale/sr@ijekavian/LC_MESSAGES/bluedevil.mo conflicts between attempted installs of kde-l10n-sr-14.12.1-1.fc22.noarch and bluedevil-5.2.0-1.fc22.x86_64
file /usr/share/locale/sr@ijekavian/LC_MESSAGES/breeze_style_config.mo conflicts between attempted installs of kde-l10n-sr-14.12.1-1.fc22.noarch and plasma-breeze-common-5.2.0-1.fc22.noarch
file /usr/share/locale/sr@ijekavian/LC_MESSAGES/drkonqi.mo conflicts between attempted installs of kde-l10n-sr-14.12.1-1.fc22.noarch and plasma-workspace-5.2.0-8.fc22.x86_64
file /usr/share/locale/sr@ijekavian/LC_MESSAGES/filetypes.mo conflicts between attempted installs of kde-l10n-sr-14.12.1-1.fc22.noarch and kde-cli-tools-5.2.0-2.fc22.x86_64
file /usr/share/locale/sr@ijekavian/LC_MESSAGES/freespacenotifier.mo conflicts between attempted installs of kde-l10n-sr-14.12.1-1.fc22.noarch and plasma-workspace-5.2.0-8.fc22.x86_64

Comment 1 Than Ngo 2015-03-03 09:30:29 UTC
i'm lookimg at this

Comment 2 Rex Dieter 2015-04-29 14:56:35 UTC
Latest kde-l10n build still has conflicts, testing -de:

Preparing...                          ########################################
	file /usr/share/doc/HTML/de/kdesu/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package kdesu-1:5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kdesu/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package kdesu-1:5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kdesu/man-kdesu.1.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package kdesu-1:5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/systemsettings/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-systemsettings-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/systemsettings/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-systemsettings-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/ksysguard/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package ksysguard-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/ksysguard/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package ksysguard-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/klipper/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-workspace-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/klipper/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-workspace-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/clock/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/colors/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/desktopthemedetails/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/joystick/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/kcmaccess/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/kcmstyle/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/solid-actions/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/splashscreen/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kfontview/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/knetattach/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/plasma-desktop/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/clock/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/colors/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/desktopthemedetails/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/joystick/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/kcmaccess/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/kcmstyle/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/solid-actions/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kcontrol/splashscreen/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kfontview/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/knetattach/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/plasma-desktop/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kmenuedit/index.cache.bz2 from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package kmenuedit-5.3.0-1.fc22.x86_64
	file /usr/share/doc/HTML/de/kmenuedit/index.docbook from install of kde-l10n-de-14.12.3-3.fc22.noarch conflicts with file from package kmenuedit-5.3.0-1.fc22.x86_64

Comment 3 Rex Dieter 2015-05-04 18:05:30 UTC
*** Bug 1218370 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Blocker Bugs Application 2015-05-04 18:11:22 UTC
Proposed as a Blocker for 22-final by Fedora user besser82 using the blocker tracking app because:

 This bug makes it not possible to install KDE-Desktop Environment from netinstall or live-image with german translation / localization

Comment 5 Björn 'besser82' Esser 2015-05-05 09:44:58 UTC
Looks like this is fixed in [1].


[1]  https://admin.fedoraproject.org/updates/FEDORA-2015-7504/kde-l10n-14.12.3-5.fc22

Comment 6 Simon Gerhards 2015-05-05 09:51:57 UTC
(In reply to Björn "besser82" Esser from comment #5)
> Looks like this is fixed in [1].
> 
> 
> [1] 
> https://admin.fedoraproject.org/updates/FEDORA-2015-7504/kde-l10n-14.12.3-5.
> fc22

Can't confirm. I still get the following error when trying to update:

Error: Transaction check error:
  file /usr/share/doc/HTML/de/knetattach/index.cache.bz2 conflicts between attempted installs of plasma-desktop-doc-5.3.0-3.fc22.x86_64 and kde-l10n-de-14.12.3-5.fc22.noarch
  file /usr/share/doc/HTML/de/knetattach/index.docbook conflicts between attempted installs of plasma-desktop-doc-5.3.0-3.fc22.x86_64 and kde-l10n-de-14.12.3-5.fc22.noarch

Comment 7 Fedora Update System 2015-05-06 11:14:11 UTC
kde-l10n-14.12.3-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-7504/kde-l10n-14.12.3-5.fc22

Comment 8 cblaauw 2015-05-07 21:06:20 UTC
I still get one error:

dnf install kde-l10n-de
Zwischenspeicher für Paketquelle »Dropbox« von »http://linux.dropbox.com/fedora/22/« kann nicht synchronisiert werden: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, wird deaktiviert.
Last metadata expiration check performed 3:27:07 ago on Thu May  7 19:36:58 2015.
Abhängigkeiten sind aufgelöst.
==========================================================================================================================================================================
 Paket                                   Arch                               Version                                     Paketquelle                                 Größe
==========================================================================================================================================================================
Installieren:
 kde-l10n-de                             noarch                             14.12.3-5.fc22                              updates-testing                              35 M

Transaktionsübersicht
==========================================================================================================================================================================
Installieren  1 Package

Gesamte Downloadgröße: 35 M
Installationsgröße: 48 M
Ist dies in Ordnung? [j/N] :j
Pakete werden heruntergeladen:
kde-l10n-de-14.12.3-5.fc22.noarch.rpm                                                                                                     1.3 MB/s |  35 MB     00:26    
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Gesamt                                                                                                                                    1.2 MB/s |  35 MB     00:28     
Transaktionsüberprüfung wird ausgeführt
Transaktionsprüfung war erfolgreich.
Transaktion wird getestet
Fehler: Fehler bei der Transaktionsüberprüfung:
  file /usr/share/doc/HTML/de/knetattach/index.cache.bz2 from install of kde-l10n-de-14.12.3-5.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-4.fc22.x86_64
  file /usr/share/doc/HTML/de/knetattach/index.docbook from install of kde-l10n-de-14.12.3-5.fc22.noarch conflicts with file from package plasma-desktop-doc-5.3.0-4.fc22.x86_64

Fehler-Zusammenfassung
----------------------

Comment 9 Fedora Update System 2015-05-11 04:08:07 UTC
kde-l10n-14.12.3-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Simon Gerhards 2015-05-11 05:43:06 UTC
(In reply to Fedora Update System from comment #9)
> kde-l10n-14.12.3-5.fc22 has been pushed to the Fedora 22 stable repository. 
> If problems still persist, please make note of it in this bug report.

Just to be clear and as stated previously: The bug is *not* fixed.

Comment 11 Kevin Kofler 2015-05-11 09:41:30 UTC
We still have the knetattach conflict left, reopening.

Comment 12 Fedora Update System 2015-05-11 18:51:20 UTC
kde-l10n-14.12.3-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kde-l10n-14.12.3-6.fc22

Comment 13 Dan Mossor [danofsatx] 2015-05-11 19:29:47 UTC
Discussed at the 2015-05-11 blocker review meeting[0]. Voted as RejectedBlocker AcceptedFreezeException.

#agreed 1197940 - RejectedBlocker AcceptedFreezeException - we don't believe it's correct that this affects live installs. That means the only scenarios that can't be fixed with an update are 'Jam live image compose' (not a blocking image) and 'network install of KDE in German with the updates repository disabled', which seems too unusual to block the release for, but accepted as an FE

[0]: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-11/

Comment 14 Sergio Basto 2015-05-12 10:48:39 UTC
*** Bug 1219583 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2015-05-12 20:36:11 UTC
Package kde-l10n-14.12.3-6.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-l10n-14.12.3-6.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8006/kde-l10n-14.12.3-6.fc22
then log in and leave karma (feedback).

Comment 16 Adam Williamson 2015-05-12 22:03:12 UTC
-6 does seem to fix the remaining issue.

Comment 17 Fedora Update System 2015-05-13 01:46:10 UTC
kde-l10n-14.12.3-6.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.