Bug 1198107 - [RFE] Add wrapper for js-import and js-export
Summary: [RFE] Add wrapper for js-import and js-export
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Yedidyah Bar David
QA Contact: Karolína Hajná
URL:
Whiteboard:
Depends On: 1232822 1232825 1258789
Blocks: 1119603
TreeView+ depends on / blocked
 
Reported: 2015-03-03 12:05 UTC by Shirly Radco
Modified: 2016-05-20 01:24 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1236757 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:16:54 UTC
oVirt Team: Integration
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0425 normal SHIPPED_LIVE rhevm-reports bug fix and enhancement update 2016-03-10 01:21:14 UTC
oVirt gerrit 42017 master MERGED packaging: Add queryEnvKey Never
oVirt gerrit 42032 master MERGED packaging: Add ovirt-engine-reports-tool Never
oVirt gerrit 42048 master MERGED packaging: setup: Move java plugin to common/common Never
oVirt gerrit 42411 master MERGED packaging: setup: Stop services only when needed Never
oVirt gerrit 42430 master MERGED packaging: setup: Stop services only when needed Never

Description Shirly Radco 2015-03-03 12:05:06 UTC
Description of problem:

Currently to export saved ad hoc reports on a reports server we run:

# export ADDITIONAL_CONFIG_DIR=/var/lib/ovirt-engine-reports/build-conf
# /usr/share/jasperreports-server/buildomatic/js-export.sh --uris /organizations/organization_1/adhoc/aru --output-zip < zip file name >.zip
To import move the zip to any rhevm reports server and run:

# export ADDITIONAL_CONFIG_DIR=/var/lib/ovirt-engine-reports/build-conf
# /usr/share/jasperreports-server/buildomatic/js-import.sh --input-zip < zip file name >.zip 

The rebase to jasper 6.0.1 made the js-import and js-export more complicated.
We need to add:
ANT_OPTS=-DmasterPropsSource=/var/lib/ovirt-engine-reports/build-conf/master.properties

We need to add a wrapper that simplify the use of these procedures.

Version-Release number of selected component (if applicable):
3.6.0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yedidyah Bar David 2015-04-21 06:57:55 UTC
Wrapper should set also PATH, see bug 1211709 .

Comment 3 Yedidyah Bar David 2015-06-01 14:28:18 UTC
Following a discussion with Yaniv and Shirly, we are going to add a script /usr/bin/ovirt-engine-reports-tool with the following options:

--export-ad-hoc-reports
--import-ad-hoc-reports
--change-admin-password
--help

Comment 4 Yedidyah Bar David 2015-06-09 10:37:36 UTC
Patches are mostly ready. Few questions:

1. Should we stop reportsd at beginning and start at end?

2. Should be backup at beginning and restore if we fail?

3. How can I test with the pro version?

Comment 5 Yaniv Lavi 2015-06-16 10:51:31 UTC
(In reply to Yedidyah Bar David from comment #4)
> Patches are mostly ready. Few questions:
> 
> 1. Should we stop reportsd at beginning and start at end?

no

> 
> 2. Should be backup at beginning and restore if we fail?

not needed.

> 
> 3. How can I test with the pro version?

Sradco will provide a env for that.

Comment 6 Max Kovgan 2015-06-28 14:13:06 UTC
ovirt-3.6.0-3 release

Comment 7 Yedidyah Bar David 2015-06-29 11:51:42 UTC
For this bug and for bug 956226 we added a new tool, part of the reports-setup package, called ovirt-engine-reports-tool. When ran without options, it asks what to do. Currently there are 3 options:

1. Change the reports admin password

2. Export saved/adhoc reports
- You are prompted for a filename to export to
- You can copy this file to some other installation of reports (of the same version) and import it using the next option

3. Import saved/adhoc reports

It's based on the same framework of engine-setup. This means, in particular, that it has similar logs, and generates an answerfile which can be used with the option '--config-append=file', in order to run unattended.

julie - we might want this in the main documentation, and/or doctext, not sure. If former we should probably open another bug to track this. Please advice and/or handle. Thanks!

Comment 8 Julie 2015-06-29 23:07:09 UTC
(In reply to Yedidyah Bar David from comment #7)
> For this bug and for bug 956226 we added a new tool, part of the
> reports-setup package, called ovirt-engine-reports-tool. When ran without
> options, it asks what to do. Currently there are 3 options:
> 
> 1. Change the reports admin password
> 
> 2. Export saved/adhoc reports
> - You are prompted for a filename to export to
> - You can copy this file to some other installation of reports (of the same
> version) and import it using the next option
> 
> 3. Import saved/adhoc reports
> 
> It's based on the same framework of engine-setup. This means, in particular,
> that it has similar logs, and generates an answerfile which can be used with
> the option '--config-append=file', in order to run unattended.
> 
> julie - we might want this in the main documentation, and/or doctext, not
> sure. If former we should probably open another bug to track this. Please
> advice and/or handle. Thanks!

Hey Didi,
   Thanks for the need_info. Since it's a new tool with important functions, we should include it in the main documentation. I have opened a docs bug (BZ#1236757) to track the work.

Just a few questions:
* Is this tool only available from 3.6 onwards?
* Which subscription manager repo contains this package and which internal repo contains this package(for internal testing)?
* Are there existing documents for this tool?

Many thanks,
Julie

Comment 9 Yedidyah Bar David 2015-06-30 07:33:01 UTC
(In reply to Julie from comment #8)
> Hey Didi,
>    Thanks for the need_info. Since it's a new tool with important functions,
> we should include it in the main documentation. I have opened a docs bug
> (BZ#1236757) to track the work.
> 
> Just a few questions:
> * Is this tool only available from 3.6 onwards?

Yes.

> * Which subscription manager repo contains this package and which internal
> repo contains this package(for internal testing)?

It's currently part of the existing package ovirt-engine-reports-setup (downstream rhevm-reports-setup).

For testing you can use the alpha release [1].

[1] http://lists.ovirt.org/pipermail/users/2015-June/033473.html

> * Are there existing documents for this tool?

Nothing except this bug.

Comment 11 Yedidyah Bar David 2015-07-13 09:35:36 UTC
Docs for this bug are covered in bug 1236757.

Comment 12 Karolína Hajná 2015-12-15 10:16:25 UTC
Verified on rhevm-3.6.1.3-0.1.el6.noarch (build 3.6.1-4)

Comment 14 errata-xmlrpc 2016-03-09 21:16:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0425.html


Note You need to log in before you can comment on or make changes to this bug.