Bug 1198217 - Mouse scrolling doesn't work in editor windows
Summary: Mouse scrolling doesn't work in editor windows
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-pydev
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1266899 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-03 15:14 UTC by Stephen Gallagher
Modified: 2015-11-01 02:37 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-23 17:20:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Eclipse Project 479580 None None None Never

Description Stephen Gallagher 2015-03-03 15:14:53 UTC
Description of problem:
Mouse scrolling doesn't work in editor windows. I can mouse-scroll on the "Project Explorer" or "Outline" frames, but not in the main editor. It works properly on other languages, so it appears to be an issue specifically with eclipse-pydev.

Version-Release number of selected component (if applicable):
eclipse-pydev-3.7.1-2.fc22.noarch

How reproducible:
Every time

Steps to Reproduce:
1. Open a python file in eclipse-pydev
2. Attempt to scroll using the mousewheel
3.

Actual results:
Nothing happens

Expected results:
The editor window should scroll.

Additional info:

Comment 1 Alexander Kurtakov 2015-05-05 10:24:31 UTC
Workaround is Window/Preferences/PyDev/Editor/Overview Ruler and select "Show vertical scrollbar" . After restart it works. I'm investigating what's behind it.

Comment 2 Antoine Martin 2015-05-30 14:01:25 UTC
Thanks for the workaround.

Comment 3 Antoine Martin 2015-07-02 13:46:28 UTC
I'm not sure if this related to pydev or not, but eclipse has a lot of problems for me in F22: I lose the control key regularly, at which point I have to switch perspective and back again to be able to use it.

Comment 4 Stephen Gallagher 2015-07-02 14:03:12 UTC
(In reply to Antoine Martin from comment #3)
> I'm not sure if this related to pydev or not, but eclipse has a lot of
> problems for me in F22: I lose the control key regularly, at which point I
> have to switch perspective and back again to be able to use it.

That's unrelated. It happens to me in a variety of applications. Impossible to reproduce consistently too.

Comment 5 Mat Booth 2015-09-30 15:46:21 UTC
*** Bug 1266899 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2015-10-14 09:54:22 UTC
eclipse-4.5.1-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6a7ea97ee8

Comment 7 Fedora Update System 2015-10-14 09:55:11 UTC
eclipse-4.5.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2e278213c3

Comment 8 Antoine Martin 2015-10-14 10:20:56 UTC
Maybe I am missing something, I downloaded the packages from bohdi then:

$ sudo dnf install eclipse-platform-4.5.1-2.fc22.x86_64.rpm eclipse-ecf-core-3.11.0-1.fc22.x86_64.rpm
Error: nothing provides eclipse-emf-core >= 1:2.11.0-1 needed by eclipse-platform-1:4.5.1-2.fc22.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)

And I cannot find a eclipse-emf-core recent enough.

Comment 9 Mat Booth 2015-10-14 12:13:31 UTC
You should wait until the update hits the "updates-testing" repository, then everything you need will be available. Bodhi should make another comment here when that happens that will tell you how to get the update, the command will be something like this:

$ sudo dnf --enablerepo=updates-testing update eclipse\*

Comment 10 Fedora Update System 2015-10-14 22:53:11 UTC
eclipse-4.5.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update eclipse'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2e278213c3

Comment 11 Fedora Update System 2015-10-15 05:52:19 UTC
eclipse-4.5.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update eclipse'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6a7ea97ee8

Comment 12 Fedora Update System 2015-10-23 17:20:44 UTC
eclipse-4.5.1-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-11-01 02:37:48 UTC
eclipse-4.5.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.