Bug 1198326 - After ice_setup runs, ceph-deploy install --repo {HOSTS} text is incorrect or can be misinterpretted.
Summary: After ice_setup runs, ceph-deploy install --repo {HOSTS} text is incorrect o...
Keywords:
Status: CLOSED DUPLICATE of bug 1254570
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer
Version: 1.2.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: 1.2.4
Assignee: Travis Rhoden
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-03 19:41 UTC by Warren
Modified: 2017-12-13 00:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-19 20:22:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 11273 0 None None None Never

Description Warren 2015-03-03 19:41:26 UTC
Description of problem:

After running ice_setup, the comments displayed says that one can install the repo on other nodes using ceph-deploy install --repo {HOSTS}

This seems to imply that ceph-deploy install --repo magna025 magna027 magna094 would
install on all 3 machines.

This command only installs on magna025.  You have to do ceph-deploy install --repo magna027 and ceph-deploy install --repo magna094 to install on the others.

Note that you can see that only magna025 is installed upon, so this is pretty easy to figure out and should not confuse too many users.


How reproducible:
100% of the time

Comment 1 Warren 2015-03-03 19:42:53 UTC
I don't think that this is an issue for ceph-deploy install without the --repo option.

Comment 2 Ken Dreyer (Red Hat) 2015-03-03 23:38:43 UTC
(retargeting to 1.2.4)

Comment 3 Travis Rhoden 2015-04-01 13:38:24 UTC
This is fixed upstream with: https://github.com/ceph/ceph-deploy/commit/c47f784e3d19dec2fc99ff4d23fe314801d1f2dd

Fix will be included in upstream release 1.5.23.

Comment 4 Ken Dreyer (Red Hat) 2015-10-19 20:22:22 UTC
This is the same issue described at 1254570

*** This bug has been marked as a duplicate of bug 1254570 ***


Note You need to log in before you can comment on or make changes to this bug.