Bug 119840 - s-c-p cannot print CUPS testprint.ps
s-c-p cannot print CUPS testprint.ps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
triage|leonardjo|closed|rawhide
: SELinux
: 120003 (view as bug list)
Depends On:
Blocks: 122683
  Show dependency treegraph
 
Reported: 2004-04-02 10:42 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.10.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-10 13:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages relating to a test print from s-c-p (5.45 KB, text/plain)
2004-04-07 13:45 EDT, Fred New
no flags Details

  None (edit)
Description Gene Czarcinski 2004-04-02 10:42:29 EST
Description of problem:
system-config-printer cannot print the CUPS test at
/usr/share/cups/data/testprint.ps .. permission denied.
Comment 1 Daniel Walsh 2004-04-02 23:09:54 EST
Please attach the avc messages from /var/log/messages.
Comment 2 Gene Czarcinski 2004-04-03 04:11:36 EST
Apr  3 04:11:24 chaos kernel: audit(1080983484.796:0): avc:  denied  {
getattr } for  pid=21839 exe=/usr/bin/lpr.cups
path=/usr/share/cups/data/testprint.ps dev=hda7 ino=930374
scontext=root:sysadm_r:sysadm_lpr_t tcontext=system_u:object_r:usr_t
tclass=file

Be sure to look at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119842
Comment 3 Tim Waugh 2004-04-05 03:29:31 EDT
*** Bug 120003 has been marked as a duplicate of this bug. ***
Comment 4 Fred New 2004-04-07 13:45:28 EDT
Created attachment 99202 [details]
/var/log/messages relating to a test print from s-c-p

I'm assuming this is the same problem, but my printer is a non-postscript
LaserJet 4L (HP-PCL3) printer on a Windows XP system.  Steps to produce these
messages:

su -
setenforce 0
/etc/cron.daily/logrotate (fruitless attempt to  reduce messages in
/var/log/messages)
system-config-printer
highlight printer, select CUPS test page (first line) from Test menu.
setenforce 1
tail -200 /var/log/message > messages-print-test
further editing with vi to remove unrelated messages from the top.

Package versions:
  policy-1.9.2-12
  policy-sources-1.9.2-12
  system-config-printer-0.6.98-1
Comment 5 Daniel Walsh 2004-04-08 10:00:55 EDT
Added some rules to fix you messages.

Policy-1.10.1-5

Note You need to log in before you can comment on or make changes to this bug.