Bug 1198717 - xalan-c package needs source update for epel ppc64le/aarch64
Summary: xalan-c package needs source update for epel ppc64le/aarch64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: xalan-c
Version: epel7
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1291377
Blocks: epel7aarch64 epel7ppc64le
TreeView+ depends on / blocked
 
Reported: 2015-03-04 17:02 UTC by Menanteau Guy
Modified: 2015-12-24 05:06 UTC (History)
3 users (show)

Fixed In Version: xalan-c-1.11.0-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-24 05:06:10 UTC


Attachments (Terms of Use)

Description Menanteau Guy 2015-03-04 17:02:57 UTC
Source package xalan-c-1.11.0-2 used by EPEL7 does not support ppc64le.
A newer version supporting this architecture should be used instead.

Comment 1 Yaakov Selkowitz 2015-11-26 00:53:23 UTC
Same applies to aarch64.  This was fixed for f21 in commit b8d9a3f (the very next commit after epel7 branched), but as there have been no code changes since, a simple merge from master will fix this.

Comment 2 Fedora Update System 2015-12-07 01:30:00 UTC
xalan-c-1.11.0-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-cf06efa4a4

Comment 3 Fedora Update System 2015-12-08 07:21:44 UTC
xalan-c-1.11.0-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update xalan-c'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-cf06efa4a4

Comment 4 Menanteau Guy 2015-12-14 10:52:07 UTC
xalan-c-1.11.0-3.el7 failed on an epel7 ppc64le.

configure: error: cannot guess build type; you must specify one

This happened because of following line in the spec:
# Update config.guess for new architectures
cp /usr/lib/rpm/config.guess config.guess

Because of the rpm-4.11.3-17 package version on redhat, /usr/lib/rpm/config.guess and config.sub comming from rpm package are not set correctly for ppc64le and these files can not be used directly. 
Note that /usr/lib/rpm/redhat/config... handle ppc64le correctly.

Comment 5 Yaakov Selkowitz 2015-12-14 17:56:24 UTC
(In reply to Menanteau Guy from comment #4)
> Because of the rpm-4.11.3-17 package version on redhat,
> /usr/lib/rpm/config.guess and config.sub comming from rpm package are not
> set correctly for ppc64le and these files can not be used directly. 
> Note that /usr/lib/rpm/redhat/config... handle ppc64le correctly.

IMO this should be fixed in RHEL rpm; I filed bug 1291377 accordingly.

Comment 6 Fedora Update System 2015-12-24 05:06:06 UTC
xalan-c-1.11.0-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.