Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1198739 - User -> My Account -> Mail Preferences - showing blank Notification section for non admin user
Summary: User -> My Account -> Mail Preferences - showing blank Notification section f...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: sthirugn@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1130651
TreeView+ depends on / blocked
 
Reported: 2015-03-04 17:45 UTC by sthirugn@redhat.com
Modified: 2017-02-23 20:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-08 00:17:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
Blank notifications section for non-admin user (36.65 KB, image/png)
2015-03-04 17:45 UTC, sthirugn@redhat.com
no flags Details

Description sthirugn@redhat.com 2015-03-04 17:45:20 UTC
Created attachment 997990 [details]
Blank notifications section for non-admin user

Description of problem:
User -> My Account -> Mail Preferences - showing blank Notification section for non admin user

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150303.0

How reproducible:
Always

Steps to Reproduce:
1. Create a non-admin user
2. Log in as the non-admin user
3. Navigate to Web UI -> User -> My Account -> Mail Preferences. 

Actual results:
See Notifications section blank

Expected results:
Notifications section should be visible for non-admin user

Additional info:
screenshot attached

Comment 2 Stephen Benjamin 2015-03-08 00:17:54 UTC
Not a bug, there's a `Mail notifications` filter.  

Create a role and add this filter to it and the user should be able to see them.

Comment 4 Stephen Benjamin 2015-03-09 13:43:20 UTC
Sure, maybe we need a separate doc bug about user permissions if there isn't any now.

You have to grant privileges to everything you want a non-privileged user to have access to.  It's deny-all by default.


Note You need to log in before you can comment on or make changes to this bug.