Bug 1198797 - Remote Install fails due to pulp error
Summary: Remote Install fails due to pulp error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: sthirugn@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1130651
TreeView+ depends on / blocked
 
Reported: 2015-03-04 20:26 UTC by sthirugn@redhat.com
Modified: 2017-02-23 20:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 05:28:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
Content host pulp error log (47.93 KB, text/plain)
2015-03-04 20:26 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2015:1592 0 normal SHIPPED_LIVE Important: Red Hat Satellite 6.1.1 on RHEL 6 2015-08-12 09:04:35 UTC

Description sthirugn@redhat.com 2015-03-04 20:26:26 UTC
Created attachment 998044 [details]
Content host pulp error log

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create multiple content views, publish, promote
2. Register/subscribe multiple content hosts to different content view
3. Attempt to apply an applicable errata on different content hosts pertaining to different content views

Actual results:
Content view is updated but failed in applying the errata to the content hosts.
Content host /var/log/messages is attached

Expected results:
Incremental update is completed

Additional info:

Comment 1 sthirugn@redhat.com 2015-03-04 20:28:24 UTC
Version Tested:
***************
Satellite-6.1.0-RHEL-6-20150303.0


In rhel 6.6 satellite 6.1:
**************************
# rpm -qa | grep pulp
pulp-puppet-tools-2.6.0-0.7.beta.el6sat.noarch
python-kombu-3.0.24-5.pulp.el6_6sat.noarch
pulp-katello-0.3-4.el6sat.noarch
pulp-rpm-plugins-2.6.0-0.7.beta.el6_6sat.noarch
python-pulp-common-2.6.0-0.7.beta.el6_6sat.noarch
python-pulp-docker-common-0.2.2-1.el6_6sat.noarch
python-pulp-bindings-2.6.0-0.7.beta.el6_6sat.noarch
pulp-server-2.6.0-0.7.beta.el6_6sat.noarch
pulp-nodes-parent-2.6.0-0.7.beta.el6_6sat.noarch
rubygem-smart_proxy_pulp-1.0.1.1-1.el6_6sat.noarch
python-pulp-rpm-common-2.6.0-0.7.beta.el6_6sat.noarch
pulp-nodes-common-2.6.0-0.7.beta.el6_6sat.noarch
pulp-selinux-2.6.0-0.7.beta.el6_6sat.noarch
pulp-docker-plugins-0.2.2-1.el6_6sat.noarch
python-isodate-0.5.0-4.pulp.el6_6sat.noarch
python-pulp-puppet-common-2.6.0-0.7.beta.el6sat.noarch
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-puppet-plugins-2.6.0-0.7.beta.el6sat.noarch



In rhel 6.6 content host:
************************
# rpm -qa | grep pulp
python-isodate-0.5.0-4.pulp.el6_6sat.noarch
pulp-rpm-handlers-2.6.0-0.7.beta.el6_6sat.noarch
python-pulp-common-2.6.0-0.7.beta.el6_6sat.noarch
python-pulp-rpm-common-2.6.0-0.7.beta.el6_6sat.noarch
python-pulp-agent-lib-2.6.0-0.7.beta.el6_6sat.noarch

Comment 3 Jeff Ortel 2015-03-04 22:25:28 UTC
Looks like an issue in the reconnect logic in the gofer proton adapter.  Fixing in gofer upstream.

Comment 5 RHEL Program Management 2015-03-05 02:26:37 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 7 Jeff Ortel 2015-03-09 21:40:52 UTC
Fixed in gofer 2.6.0.

Comment 9 sthirugn@redhat.com 2015-03-23 17:15:08 UTC
Verified.

Satellite-6.1.0-RHEL-6-20150317.0

Comment 10 Bryan Kearney 2015-08-11 13:27:03 UTC
This bug is slated to be released with Satellite 6.1.

Comment 11 errata-xmlrpc 2015-08-12 05:28:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2015:1592


Note You need to log in before you can comment on or make changes to this bug.