Bug 1198953 - KeyError: 'server-product-environment'
Summary: KeyError: 'server-product-environment'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e1a578bf0d105b0b15df991f03a...
: 1206630 1206685 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-05 08:01 UTC by A.J. Werkman
Modified: 2015-04-27 17:47 UTC (History)
11 users (show)

Fixed In Version: python-blivet-1.0.6-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-06 18:48:30 UTC


Attachments (Terms of Use)
File: anaconda-tb (392.40 KB, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: anaconda.log (11.20 KB, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: dnf.log (5.01 KB, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: environ (492 bytes, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: lsblk_output (3.06 KB, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: nmcli_dev_list (997 bytes, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: os_info (443 bytes, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: storage.log (112.64 KB, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: syslog (123.30 KB, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: ifcfg.log (2.27 KB, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: packaging.log (319 bytes, text/plain)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details
File: program.log (47.65 KB, application/octet-stream)
2015-03-05 08:01 UTC, A.J. Werkman
no flags Details

Description A.J. Werkman 2015-03-05 08:01:34 UTC
Description of problem:
After accepting my fath, this bug comes up.

Version-Release number of selected component:
anaconda-22.20.1-1

The following was filed automatically by anaconda:
anaconda 22.20.1-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 370, in _allAddons
    [""] + \
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 376, in _get_selected_addons
    addons = self._allAddons()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 110, in _apply
    addons = self._get_selected_addons()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 243, in _initialize
    self._apply()
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 238, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 92, in get
    self.raise_if_error(name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 190, in ready
    return bool(not threadMgr.get(constants.THREAD_SOFTWARE_WATCHER) and
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 198, in _updateCompleteness
    spoke.selector.set_sensitive(spoke.sensitive and spoke.ready)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 272, in _update_spokes
    self._updateCompleteness(spoke)
KeyError: 'server-product-environment'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:UUID=e8507ec4-a731-44e5-8e24-729e418227e3
dnf.rpm.log:    Mar 05 07:56:23 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 A.J. Werkman 2015-03-05 08:01:37 UTC
Created attachment 998214 [details]
File: anaconda-tb

Comment 2 A.J. Werkman 2015-03-05 08:01:39 UTC
Created attachment 998215 [details]
File: anaconda.log

Comment 3 A.J. Werkman 2015-03-05 08:01:40 UTC
Created attachment 998216 [details]
File: dnf.log

Comment 4 A.J. Werkman 2015-03-05 08:01:41 UTC
Created attachment 998217 [details]
File: environ

Comment 5 A.J. Werkman 2015-03-05 08:01:42 UTC
Created attachment 998218 [details]
File: lsblk_output

Comment 6 A.J. Werkman 2015-03-05 08:01:43 UTC
Created attachment 998219 [details]
File: nmcli_dev_list

Comment 7 A.J. Werkman 2015-03-05 08:01:44 UTC
Created attachment 998220 [details]
File: os_info

Comment 8 A.J. Werkman 2015-03-05 08:01:46 UTC
Created attachment 998221 [details]
File: storage.log

Comment 9 A.J. Werkman 2015-03-05 08:01:48 UTC
Created attachment 998222 [details]
File: syslog

Comment 10 A.J. Werkman 2015-03-05 08:01:49 UTC
Created attachment 998223 [details]
File: ifcfg.log

Comment 11 A.J. Werkman 2015-03-05 08:01:50 UTC
Created attachment 998224 [details]
File: packaging.log

Comment 12 A.J. Werkman 2015-03-05 08:01:51 UTC
Created attachment 998225 [details]
File: program.log

Comment 13 David Shea 2015-03-05 14:31:21 UTC
What install media are you using? This looks like the data from the installclass about the default environment to use (server-product-environment) doesn't match what you actually have in comps.xml.

Comment 14 Adam Williamson 2015-03-27 01:44:23 UTC
Another user experienced a similar problem:

Booted Fedora 22 Beta TC5 Server DVD x86_64 to hub. May be related to a dependency issue in the DVD package set (noticed it in the compose log dennis posted to trac), but anaconda shouldn't crash for such a problem.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-22_B_T5-x86_64 quiet
dnf.rpm.log:    Mar 27 01:40:27 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         4.0.0-0.rc4.git0.1.fc22.x86_64
package:        anaconda-22.20.6-1
product:        Fedora"
reason:         KeyError: 'server-product-environment'
release:        Cannot get release name.
version:        Fedora

Comment 15 Adam Williamson 2015-03-27 01:45:09 UTC
Re-opening...

Comment 16 Adam Williamson 2015-03-27 01:53:15 UTC
Indeed the comps file in /run/install/repo/repodata on the DVD does not seem to include 'server-product-environment' - it has 'server-product'. comps-f22.xml.in in comps git *does* have 'server-product-environment'.

The dep issue on the DVD is that 'cockpit-docker' is on the DVD, but 'docker' is not, and cockpit-docker requires docker.

Comment 17 Adam Williamson 2015-03-27 01:55:15 UTC
cockpit requires cockpit-docker , so cockpit's dep chain is broken. cockpit is a mandatory package for the 'headless-management' group, which is a part of the 'server-product-environment' group.

So, I'm gonna guess that comps generation encountered that dep issue and it causes the env group to be thrown out of comps?

Comment 18 Dan Horák 2015-03-27 07:50:04 UTC
This bug also affects secondaries where docker doesn't exist.

Comment 19 A.J. Werkman 2015-03-27 08:56:09 UTC
Another user experienced a similar problem:

Normal network installation of Server using a proxy.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz proxy=http://thlin.digifarma.nl:3128/ ip=172.18.92.70::172.18.92.65:255.255.255.192:cfl.lc.digifarma.nl::off noipv6 nameserver=172.18.92.65 inst.stage2=hd:UUID=53ec59b4-5e27-4f54-971c-12228bf71b13 inst.repo=http://thlin.digifarma.nl/fedora/development/22_Beta_TC5/Server/x86_64/os
dnf.rpm.log:    Mar 27 11:34:52 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         4.0.0-0.rc4.git0.1.fc22.x86_64
package:        anaconda-22.20.6-1
product:        Fedora"
reason:         KeyError: 'server-product-environment'
release:        Cannot get release name.
version:        Fedora

Comment 20 David Shea 2015-03-27 11:34:16 UTC
https://github.com/rhinstaller/anaconda/pull/53 oughta take care of it. If the instclass environment isn't in the comps data, for whatever reason, it'll fall back to picking the first environment listed.

Comment 21 David Shea 2015-03-27 15:08:32 UTC
*** Bug 1206630 has been marked as a duplicate of this bug. ***

Comment 22 David Shea 2015-03-27 18:46:16 UTC
*** Bug 1206685 has been marked as a duplicate of this bug. ***

Comment 23 Mike Ruckman 2015-03-30 21:42:15 UTC
Another user experienced a similar problem:

Selected default language, clicked continue. Crash happened immediately after the hub loaded.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22_B_T5-x86_64 quiet
dnf.rpm.log:    Mar 30 21:40:15 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         4.0.0-0.rc4.git0.1.fc22.x86_64
package:        anaconda-22.20.6-1
product:        Fedora"
reason:         NoSuchGroup: server-product-environment
release:        Cannot get release name.
version:        Fedora

Comment 24 Fedora Update System 2015-04-02 18:25:43 UTC
anaconda-22.20.8-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/anaconda-22.20.8-1.fc22

Comment 25 Fedora Update System 2015-04-04 16:32:27 UTC
Package python-blivet-1.0.6-1.fc22, anaconda-22.20.8-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-1.0.6-1.fc22 anaconda-22.20.8-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5530/python-blivet-1.0.6-1.fc22,anaconda-22.20.8-1.fc22
then log in and leave karma (feedback).

Comment 26 Fedora Update System 2015-04-06 18:48:30 UTC
python-blivet-1.0.6-1.fc22, anaconda-22.20.8-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.