Bug 1206685 - KeyError: 'server-product-environment'
Summary: KeyError: 'server-product-environment'
Keywords:
Status: CLOSED DUPLICATE of bug 1198953
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: armv7l
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f27727b0d0aac211121534d4332...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-27 18:41 UTC by Paul Whalen
Modified: 2015-03-27 18:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-27 18:46:16 UTC


Attachments (Terms of Use)
File: anaconda-tb (306.73 KB, text/plain)
2015-03-27 18:41 UTC, Paul Whalen
no flags Details
File: anaconda.log (9.15 KB, text/plain)
2015-03-27 18:41 UTC, Paul Whalen
no flags Details
File: dnf.log (6.68 KB, text/plain)
2015-03-27 18:41 UTC, Paul Whalen
no flags Details
File: environ (492 bytes, text/plain)
2015-03-27 18:41 UTC, Paul Whalen
no flags Details
File: lsblk_output (1.90 KB, text/plain)
2015-03-27 18:41 UTC, Paul Whalen
no flags Details
File: nmcli_dev_list (1.01 KB, text/plain)
2015-03-27 18:41 UTC, Paul Whalen
no flags Details
File: os_info (443 bytes, text/plain)
2015-03-27 18:41 UTC, Paul Whalen
no flags Details
File: storage.log (91.63 KB, text/plain)
2015-03-27 18:41 UTC, Paul Whalen
no flags Details
File: syslog (64.11 KB, text/plain)
2015-03-27 18:41 UTC, Paul Whalen
no flags Details
File: ifcfg.log (1.58 KB, text/plain)
2015-03-27 18:42 UTC, Paul Whalen
no flags Details
File: packaging.log (235 bytes, text/plain)
2015-03-27 18:42 UTC, Paul Whalen
no flags Details
File: program.log (44.56 KB, application/octet-stream)
2015-03-27 18:42 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2015-03-27 18:41:49 UTC
Description of problem:
Attempted pxe install of 22_Beta_TC5 from the Server repo 

Version-Release number of selected component:
anaconda-22.20.6-1

The following was filed automatically by anaconda:
anaconda 22.20.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 376, in _allAddons
    [""] + \
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 382, in _get_selected_addons
    addons = self._allAddons()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 116, in _apply
    addons = self._get_selected_addons()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 249, in _initialize
    self._apply()
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 238, in run
    threading.Thread.run(self, *args, **kwargs)
KeyError: 'server-product-environment'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   console=ttyS0,115200 ip=eth0:dhcp inst.repo=http://dl.fedoraproject.org/pub/alt/stage/22_Beta_TC5/Server/armhfp/os/
dnf.rpm.log:    Jan 01 00:12:17 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.0-0.rc4.git0.1.fc22.armv7hl
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 Paul Whalen 2015-03-27 18:41:51 UTC
Created attachment 1007426 [details]
File: anaconda-tb

Comment 2 Paul Whalen 2015-03-27 18:41:52 UTC
Created attachment 1007427 [details]
File: anaconda.log

Comment 3 Paul Whalen 2015-03-27 18:41:53 UTC
Created attachment 1007428 [details]
File: dnf.log

Comment 4 Paul Whalen 2015-03-27 18:41:54 UTC
Created attachment 1007429 [details]
File: environ

Comment 5 Paul Whalen 2015-03-27 18:41:55 UTC
Created attachment 1007430 [details]
File: lsblk_output

Comment 6 Paul Whalen 2015-03-27 18:41:56 UTC
Created attachment 1007431 [details]
File: nmcli_dev_list

Comment 7 Paul Whalen 2015-03-27 18:41:57 UTC
Created attachment 1007432 [details]
File: os_info

Comment 8 Paul Whalen 2015-03-27 18:41:58 UTC
Created attachment 1007433 [details]
File: storage.log

Comment 9 Paul Whalen 2015-03-27 18:41:59 UTC
Created attachment 1007434 [details]
File: syslog

Comment 10 Paul Whalen 2015-03-27 18:42:00 UTC
Created attachment 1007435 [details]
File: ifcfg.log

Comment 11 Paul Whalen 2015-03-27 18:42:01 UTC
Created attachment 1007436 [details]
File: packaging.log

Comment 12 Paul Whalen 2015-03-27 18:42:02 UTC
Created attachment 1007437 [details]
File: program.log

Comment 13 David Shea 2015-03-27 18:46:16 UTC

*** This bug has been marked as a duplicate of bug 1198953 ***


Note You need to log in before you can comment on or make changes to this bug.