Bug 119917 - Selection of LANG=en_US.UTF8 causes problems with xemacs
Summary: Selection of LANG=en_US.UTF8 causes problems with xemacs
Status: CLOSED DUPLICATE of bug 119240
Alias: None
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-03 04:14 UTC by Erwin J. Prinz
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of xemacs started with LANG=en_US.UTF-8 (49.34 KB, image/png)
2004-04-07 03:06 UTC, Erwin J. Prinz
no flags Details

Description Erwin J. Prinz 2004-04-03 04:14:15 UTC
Description of problem:

I installed FC2T2 and added a new user. By default, LANG is set as
en_US.UTF8 in the file /etc/sysconfig/i18n. With this setting, xemacs
behaves strangely, popping up text entry windows at inconvenient
points. The solution is to set LANG=en_US before starting xemacs.

Version-Release number of selected component (if applicable):
anaconda-9.91-7, xemacs-21.4.15-3

How reproducible: 100%


Steps to Reproduce:
1. export LANG=en_US.UTF-8; xemacs
2. try to select text with text commands (cntl-space ...). Surprise.
3. export LANG=en_US; xemacs
4. repeat 2. Everything is normal ...
  

Expected results:
Ideally, either xemacs would start up with the correct LANG setting.

Comment 1 Jens Petersen 2004-04-05 23:26:50 UTC
Not sure what you mean by "popping up text entry windows"?

Is this an everything install?  Are you running KDE or GNOME?

Does unsetting XMODIFIERS help when running xemacs in en_US.UTF-8.

Comment 2 Erwin J. Prinz 2004-04-07 03:06:27 UTC
Created attachment 99178 [details]
Screenshot of xemacs started with LANG=en_US.UTF-8

This attachment shows a screenshot taken when xemacs is started with
LANG=en_US.UTF-8

Comment 3 Erwin J. Prinz 2004-04-07 03:28:15 UTC
See the attachment for what I mean with popping up windows. I think it
is an entry mode for 2-byte characters of xemacs. This is an
everything install, and I am running GNOME.
I found that after the install many services are running. If I stop
IIim (sp?) the weird behavior with xemacs goes away. So, I need 3
necessary conditions to induce the behavior:
1. LANG set as en_US.UTF-8
2. "htt" (IIim) running
3. xemacs started WITHOUT LANG=en_US

It is possible that this "bug" is really a feature, but since I didn't
know what IIim does I didn't switch it off right away. I recommend to
only switch necessary services on after installation.

Comment 4 Jens Petersen 2004-04-07 11:34:38 UTC
Thanks for the screenshot: yep that is caused by the htt input method
being activated for all locale by mistake if the htt server is
running in FC2 test2.


*** This bug has been marked as a duplicate of 119240 ***

Comment 5 Jens Petersen 2004-04-07 11:35:52 UTC
I forgot to say that this is fixed in xinitrc-3.38 and later.

Comment 6 Red Hat Bugzilla 2006-02-21 19:02:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.