Bug 119240 - xinput should only turn on IIIMF for Asian locale
xinput should only turn on IIIMF for Asian locale
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 119083 119917 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-26 18:39 EST by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.38-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-30 02:51:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to avoid htt for European langs and lots of other cleanup (3.42 KB, patch)
2004-03-30 02:14 EST, Jens Petersen
no flags Details | Diff

  None (edit)
Description Jens Petersen 2004-03-26 18:39:35 EST
Description of problem:
As reported in bug 118588 by lxo, for an everything
install iiimf gets turned on even for European languages
where it is not useful.

Version-Release number of selected component (if applicable):
xinitrc-3.37-1

How reproducible:
every time

Steps to Reproduce:
1. Install iiimf-*
2. Start en_US gnome session
3. Start gtk2 or XIM application
  
Actual results:
XIM and iiimf IM turned on

Expected results:
No input method being used.
Comment 1 Mike A. Harris 2004-03-28 07:46:52 EST
Why is this marked as "fixed in xinitrc-3.38-0"?  I have not checked
any new changes into CVS for this, nor built a xinitrc-3.38-0
package.  No package exists in dist-fc2, dist-fc2-scratch,
dist-fc2-HEAD, dist-fc2-hold.  Was this closed by mistake?
Comment 2 Alexandre Oliva 2004-03-28 14:03:27 EST
Jens built this package and handed it to me for testing.  I thought it
was going to be in rawhide soon.
Comment 3 Mike A. Harris 2004-03-29 16:25:16 EST
lxo:  Ah, just a bit of confusion.  ;o)

Ok, I've made some cleanups to the xinput script both for this issue,
the missing ']' issue, another issue of using || instead of -o that
was present and changed to using -n instead of tests for != "".

This will be in the next build.  I don't know what happened to jens
patch though, I think I lost it in email.

Jens, can you attach your patches to bugzilla?
Comment 4 Jens Petersen 2004-03-30 02:08:02 EST
Ugh, my patch did all that too pretty much I think. :-(
Comment 5 Jens Petersen 2004-03-30 02:14:16 EST
Created attachment 98954 [details]
patch to avoid htt for European langs and lots of other cleanup

The patch I mailed on Saturday night to Mike.
Comment 6 Mike A. Harris 2004-03-30 02:51:17 EST
Thanks Jens, I've added a few more of your fixes, as well as a host
full of my own fixes to the various scripts also.  The complete
details are in the xinitrc-3.38 specfile changelog.  Please review
a diff of the changes between 3.37 and 3.38 for glaring goofups if
you have the time to have a peek, as a second set of eyes passing over
my changes would be a good idea.  I studied a diff between the two
for problems and didn't spot anything obvious, but it doesn't hurt.

;o)

Closing as fixed in 3.38-1 in rawhide. (dist-fc2-hold currently)
Comment 7 Jens Petersen 2004-04-05 23:02:31 EDT
*** Bug 119083 has been marked as a duplicate of this bug. ***
Comment 8 Jens Petersen 2004-04-07 07:34:40 EDT
*** Bug 119917 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.