Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1199252 - default html mime configuration
Summary: default html mime configuration
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-session
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F23FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-03-05 18:18 UTC by Raphael Groner
Modified: 2015-09-01 18:31 UTC (History)
16 users (show)

Fixed In Version: 4.12.1-5.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-01 18:31:55 UTC
Type: Bug


Attachments (Terms of Use)
mime type editor showing wrong configuration for html (528.76 KB, image/png)
2015-03-05 18:18 UTC, Raphael Groner
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1243049 0 unspecified CLOSED Rename of defaults.list to gnome-mimeapps.list is breaking other apps 2021-02-22 00:41:40 UTC

Internal Links: 1243049

Description Raphael Groner 2015-03-05 18:18:21 UTC
Created attachment 998499 [details]
mime type editor showing wrong configuration for html

Description of problem:
There's a wrong configuration given as default for html documents.

Version-Release number of selected component (if applicable):
rawhide (as of 2015-03-05)

How reproducible:
yes

Steps to Reproduce:
1. install xfce rawhide
2. go to menu > documentation > Fedora release notes
3.

Actual results:
Geany starts with a textual display of the html page.

Expected results:
Browser should be chosen to render properly the html page.

Additional info:
I'll attach a sample screen shot.

Not sure if xfconf is the right component to blame for that.

Comment 1 Raphael Groner 2015-03-05 18:19:35 UTC
Besides that, Abiword is configured to open xhtml+xml. That should also be changed to a valid browser application, e.g. Midori.

Comment 2 Mukundan Ragavan 2015-03-06 00:28:38 UTC
That's really strange. Let me look.

Comment 3 Mukundan Ragavan 2015-03-06 01:36:21 UTC
Ok, the problem is gtk-find icon seems to be missing from gnome icon themes. Only theme that seems have the icon theme is Rodent - which brings back the nice magnifying glass icon.

Comment 4 Mukundan Ragavan 2015-03-06 01:37:03 UTC
Darn it! Wrong bug report! Sorry!

Comment 5 Kevin Fenzi 2015-03-07 14:18:19 UTC
This may be a geany bug... 

it has: 

MimeType=text/plain;text/x-chdr;text/x-csrc;text/x-c++hdr;text/x-c++src;text/x-java;text/x-dsrc;text/x-pascal;text/x-perl;text/x-python;application/x-php;application/x-httpd-php3;application/x-httpd-php4;application/x-httpd-php5;application/xml;text/html;text/css;text/x-sql;text/x-diff;

in it's desktop file. 

If you remove geany, what do you get for the release notes?

Comment 6 Raphael Groner 2015-03-07 16:08:56 UTC
(In reply to Kevin Fenzi from comment #5)
> This may be a geany bug... > If you remove geany, what do you get for the release notes?

Okay, that was the right hint. If there's both no geany *and* no abiword installed (by yum remove geany abiword), the release notes get open in midori.

Comment 7 Mukundan Ragavan 2015-03-19 01:26:02 UTC
(In reply to Raphael Groner from comment #6)
> 
> Okay, that was the right hint. If there's both no geany *and* no abiword
> installed (by yum remove geany abiword), the release notes get open in
> midori.

Shall I close this bug now that it has been ascertained that it's not xfconf?

Comment 8 Raphael Groner 2015-03-19 13:04:12 UTC
How do you want to tell the end-user to remove any by default installed editor (geany, abiword, whatever…) from the running live spin to be able to read the release notes properly?

There should be a patch for xdg-open to enforce the default webbrowser for an html file.

$ grep Exec /usr/share/applications/fedora-release-notes.desktop 
Exec=xdg-open file:///usr/share/doc/fedora-release-notes/index.html

Reassigning to geany in the hope to get the "text/html" entry removed there. Same must be done later for abiword.

Comment 9 Raphael Groner 2015-03-19 15:18:18 UTC
No. It's ridiculous to assume that no other application will modify the mime configuration at any time. So this bug goes against fedora-release-notes package itself: Enforce that a web browser is installed that can render the notes properly and that browser is used therefore.

Comment 10 Kevin Fenzi 2015-03-21 13:02:32 UTC
So, does this only happen in the Xfce spin? If so we may be able to set things in the kickstart so it works correctly. 

However, if the problem is more wide than that, perhaps we should look at a fix in xdg-open instead?

Comment 11 Rex Dieter 2015-03-23 14:56:03 UTC

If xfce wan't to ship custom default applications/mimetypes (that vary from distro defaults), one way to do that is to follow:

http://standards.freedesktop.org/mime-apps-spec/mime-apps-spec-1.0.html#file

and ship a customized

/usr/share/applications/xfce-mimeapps.list

Comment 12 Raphael Groner 2015-03-23 20:16:37 UTC
I do not like the idea to use xdg-open. In case of Xfce, it is better to use:

exo-open --launch WebBrowser file://%{_docdir}/%{name}/index.html

This will ensure the release notes do always open in the default web browser what is the commonly expected behaviour when the menu entry gets clicked, without touching mime configuration at all. If the user may wish, there could be an editor (or whatever other application) as default to open any html file.

From the package's spec file I can see that for GNOME, there's already a separate desktop file to show with epiphany instead.

Comment 13 Raphael Groner 2015-03-23 20:20:50 UTC
http://docs.xfce.org/xfce/exo/preferred-applications

Comment 14 Pete Travis 2015-04-11 18:22:20 UTC
I can do a desktop file just for XFCE.... but are you really that attached to the idea of an editor being the default handler for HTML files?  I think this is not what users would generally expect, regardless of whether the file opening is initiated from a menu launcher or double clicking a file or whatever.

Comment 15 Rex Dieter 2015-04-11 18:28:00 UTC
I still think some variant of custom mimetype defaults (comment #11) possibly combined with exo preferred apps (comment #13) is the way to go here.

In short, it's a xfce configuration issue, definitely not a release notes bug (as is assigned now).

Comment 16 Kevin Fenzi 2015-04-12 20:14:58 UTC
(In reply to Rex Dieter from comment #15)
> I still think some variant of custom mimetype defaults (comment #11)
> possibly combined with exo preferred apps (comment #13) is the way to go
> here.

I agree. I've just not had time to work on the defaults, and the last f22 nightly I tried things worked out of the box. 
> 
> In short, it's a xfce configuration issue, definitely not a release notes
> bug (as is assigned now).

I agree.

Comment 17 Raphael Groner 2015-04-12 20:44:46 UTC
Reassigning back to xfce specific then, exo seems to be a good base component.

Comment 18 Raphael Groner 2015-04-29 21:12:21 UTC
An installed Xfce 4.12 of Fedora 22 Beta-3 with current updates still opens the Release Notes in Abiword.

Comment 19 Jan Kurik 2015-07-15 14:26:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23

Comment 20 Raphael Groner 2015-07-27 14:20:53 UTC
Reverting to rawhide. This bug is not fixed yet.

Comment 21 Raphael Groner 2015-07-29 12:50:04 UTC
Still reproducible with latest Fedora-Live-Xfce-x86_64-23-20150728.iso

Comment 22 Kevin Fenzi 2015-07-29 15:08:52 UTC
Yes, I know. I have simply not yet had time to deal with this. 

It's on my todo list. will try and get to it soon.

Comment 23 Rex Dieter 2015-07-29 15:23:34 UTC
This may be mitigated a bit by

shared-mime-info-1.4-6

http://pkgs.fedoraproject.org/cgit/shared-mime-info.git/commit/?id=458290b30b7b97a024dcd564ed0ac7c3fc3f2a97

Comment 24 Kevin Fenzi 2015-07-29 15:34:34 UTC
Sure, but we still want/need a xfce specific one... :)

Comment 25 Raphael Groner 2015-08-01 08:40:38 UTC
Could it be solved with bug #1243049 ?

Comment 26 Raphael Groner 2015-08-01 12:55:25 UTC
Applied the update of shared-mime-info from bug #1243049 but it did not change anything for the wrong mime type configuration of html (standard for text/html is Geany as mime type editor tells me, Abiword for application/xhtml+xml). Tested both in f22 and f23 with all latest updates installed.

shared-mime-info-1.4-6.fc23.x86_64
shared-mime-info-1.4-6.fc22.x86_64

Comment 27 Rex Dieter 2015-08-01 15:48:38 UTC
Odd,

$ grep html /usr/share/applications/mimeapps.list 
text/html=firefox.desktop
application/xhtml+xml=firefox.desktop

It should default to firefox now.

Comment 28 Raphael Groner 2015-08-01 15:50:28 UTC
We don't ship Firefox in the Xfce Live Spin (any more). But there's Midori.

Comment 29 Rex Dieter 2015-08-01 15:51:27 UTC
ok, that would indeed be the problem here (and why a custom xfce-mimeapps.list would be required)

Comment 30 Kevin Fenzi 2015-08-08 17:38:21 UTC
So, thinking about it, I think we should ship this in xfce4-session. It's the place that sets the session that this would use, so you need it to use the mimeapps list anyhow. 

Toward that end, I have pushed out to rawhide: 

https://koji.fedoraproject.org/koji/taskinfo?taskID=10648917

would like to let it get some testing there (we should be able to check rawhide live media after today). 

If that looks good we can push to f23.

Comment 31 Raphael Groner 2015-08-12 13:52:46 UTC
Fedora-Live-Xfce-x86_64-rawhide-20150811.iso does NOT show this issue, so it's fixed. Thanks!

Comment 32 Raphael Groner 2015-08-12 14:10:09 UTC
This seems to be a failure of Testcase desktop menus.
https://fedoraproject.org/wiki/QA:Testcase_desktop_menus

Comment 33 Kevin Fenzi 2015-08-13 21:53:35 UTC
I'm confused... this should be fixed? or why is it a menu failure?

Comment 34 Raphael Groner 2015-08-14 06:09:15 UTC
From the test expectation:
" Each application in the default system menu layout should launch without crashing and withstand basic usage. Bugs should be filed in any case where this does not happen "

Comment 35 Kevin Fenzi 2015-08-14 20:12:25 UTC
So choosing release notes from the menu causes a crash? 

Or works? In comment 31 you said it worked?

Comment 36 Raphael Groner 2015-08-14 20:40:59 UTC
It's now fine in f24 image. But we have to ensure it's also working for -final- f23 spin image.

Comment 37 Adam Williamson 2015-08-20 18:29:04 UTC
Discussed at 2015-08-20 blocker review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-20/f23-blocker-review.2015-08-20-16.05.log.txt . Accepted as a blocker per cited criterion: Xfce is now a release-blocking desktop for ARM, and we expect this bug is present in the ARM image.

Comment 38 Fedora Update System 2015-08-20 18:37:15 UTC
xfce4-session-4.12.1-5.fc23 has been submitted as an update to Fedora 23. https://bugzilla.redhat.com/show_bug.cgi?id=1199252

Comment 39 Fedora Update System 2015-08-22 16:25:16 UTC
xfce4-session-4.12.1-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update xfce4-session'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13841

Comment 40 Raphael Groner 2015-08-25 20:40:35 UTC
Thanks. This works now in updated Fedora 23 nightly.

Comment 41 Fedora Update System 2015-09-01 18:31:50 UTC
xfce4-session-4.12.1-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.