Bug 1243049 - Rename of defaults.list to gnome-mimeapps.list is breaking other apps
Summary: Rename of defaults.list to gnome-mimeapps.list is breaking other apps
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-session
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-14 16:07 UTC by Jaroslav Škarvada
Modified: 2015-08-01 08:40 UTC (History)
6 users (show)

Fixed In Version: shared-mime-info-1.4-6.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-01 02:27:39 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1199252 0 unspecified CLOSED default html mime configuration 2021-02-22 00:41:40 UTC

Internal Links: 1199252

Description Jaroslav Škarvada 2015-07-14 16:07:44 UTC
Description of problem:
I am not sure why it was renamed, but it seems that other apps also use the defaults.list. E.g. update-desktop-database from desktop-file-utils and probably many others. Rename resulted in mimeinfo.cache generated with totally bogus entries after upgrade to F22 (e.g. HTTP opened by Konqueror, HTTPS by Chromium and PNG by Internet Explorer through Wine :)

Version-Release number of selected component (if applicable):
shared-mime-info-1.4-2.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Installed Xfce desktop on F21
2. Upgraded to F22

Actual results:
Bogus entries in mimeinfo.cache not taking into account defaults.list

Expected results:
Correct mimeninfo.cache

Additional info:
As Fedora officially supports multiple desktop environments, and the default list is provided only by one package, this file shouldn't be desktop centric.

Comment 1 Rex Dieter 2015-07-14 16:19:57 UTC
xdg spec allows for DE-mimeapps.list , any app or desktop that doesn't work as expected due to that... is an app/desktop bug.

That said, yes, it could be argued that gnome-mimeapps.list should be packaged elsewhere, but that's beside the point here (and otherwise mostly harmless when not using gnome).

Comment 2 Jaroslav Škarvada 2015-07-14 16:23:25 UTC
(In reply to Rex Dieter from comment #1)
> xdg spec allows for DE-mimeapps.list , any app or desktop that doesn't work
> as expected due to that... is an app/desktop bug.
> 
> That said, yes, it could be argued that gnome-mimeapps.list should be
> packaged elsewhere, but that's beside the point here (and otherwise mostly
> harmless when not using gnome).

Nothing against. The problem is that there were distro wide defaults that are no more.

Comment 3 Rex Dieter 2015-07-14 16:27:00 UTC
Since you're using xfce, triaging to xfce4-session component.

I vaguely recall there already being an xfce bug about this or something similar, but I was unable to find it.

Comment 4 Rex Dieter 2015-07-14 16:29:25 UTC
In short, it is generally DE's job to specify their own defaults now.

Though I agree in principal that perhaps fedora could ship some generic distro defaults too, but... we'd need to find someone able/interested in maintaining that (fedora workstation folks are primarily interested in suppporting gnome-mimeapps.list)

Comment 5 Jaroslav Škarvada 2015-07-15 09:05:30 UTC
There were distro wide defaults making the behaviour of Fedora distro consistent over all DEs that have been shipped since all the time I can remember. They are no more and it seems that Fedora workstation folks do not care. Kevin what's your opinion? Most of the DEs are currently hardly usable without sensible defaults. I think this needs wider coordination to resolve.

Comment 6 Kevin Fenzi 2015-07-15 20:39:22 UTC
So, I have had on my list for a while to make a Xfce specific one of these, but I was not aware the generic default one was removed entirely, that seems non ideal. 

Yes, I think we should discuss this on devel list some. I'll start a thread.

Personally, I'd like to see the generic one come back and then desktops (if they wished) could also ship their own.

Comment 7 Rex Dieter 2015-07-15 20:42:19 UTC
On second thought, I agree with the sentiments expressed here, that fedora probably ought to include some sort of global defaults, and then DE's would only have to define custom items that vary from those defaults.

I think a good starting point for defaults would be what fedora workstation uses, ie, gnome-mimeapps.list

Comment 8 Fedora Update System 2015-07-29 13:43:10 UTC
shared-mime-info-1.4-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/shared-mime-info-1.4-6.fc22

Comment 9 Fedora Update System 2015-07-30 13:56:11 UTC
Package shared-mime-info-1.4-6.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing shared-mime-info-1.4-6.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12356/shared-mime-info-1.4-6.fc22
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-08-01 02:27:39 UTC
shared-mime-info-1.4-6.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.