Bug 1199270 - Missing high contrast icons
Summary: Missing high contrast icons
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-themes-standard
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Cosimo Cecchi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On: 1130794 1175847
Blocks: F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-03-05 19:07 UTC by Sandra McCann
Modified: 2015-03-18 17:17 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1175847
Environment:
Last Closed: 2015-03-18 17:17:30 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
screenshot of overview (F22 Alpha) (788.94 KB, image/png)
2015-03-11 18:06 UTC, Michael Catanzaro
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 737990 0 None None None Never

Description Sandra McCann 2015-03-05 19:07:29 UTC
+++ This bug was initially created as a clone of Bug #1175847 +++

+++ This bug was initially created as a clone of Bug #1130794 +++

Description of problem: All applications installed by default in Fedora Workstation should have a high contrast icon. The following icons do not in Fedora-22-TC8 Workstation live iso:
   - Rythmbox
   - Color Profile Viewer
   - SELinux Troubleshooter  (under sundry)

(Image https://dl.fedoraproject.org/pub/alt/stage/22_Alpha_TC8/Workstation/x86_64/iso/Fedora-Live-Workstation-x86_64-22_Alpha-TC8.iso)


Version-Release number of selected component (if applicable): 


How reproducible: Always


Steps to Reproduce:
1. Go to System Settings -> Universal Access and turn on High Contrast
2. Go to the overview and look at the apps missing high contrast icons

Actual results: The three listed apps  display a hicolor icon


Expected results:All default apps display a high contrast icon


GNOME-shell version Version 3.15.90

Comment 1 Adam Williamson 2015-03-09 16:50:42 UTC
Discussed at 2015-03-09 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-09/f22-blocker-review.2015-03-09-16.05.log.txt . Accepted as a Final blocker per criterion https://fedoraproject.org/wiki/Fedora_22_Final_Release_Criteria#Default_application_functionality :

"All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy."

and the Applications and Launchers policy, https://fedoraproject.org/wiki/Workstation/Guidelines/Applications_and_Launchers :

"App launchers MUST have a unique 128×128 launcher icon with an alpha channel and a matching High Contrast icon."

Workstation folks, this bug *IS NOW BLOCKING* Fedora 22 Final release. i.e. if we don't have a high-contrast icon for these apps (and all others installed by default) by the day of the Final Go/No-Go meeting, we are required to delay the release. If you don't really want us to slip for releases for icon polish issues, please revise the policy before then, or propose decoupling it from the release criteria.

Thanks!

Comment 2 Michael Catanzaro 2015-03-09 18:11:33 UTC
I highly doubt we would slip for an icon polish issue: that would be silly. The point of the criterion IMO is to ensure we remove the offending apps if they're not fixed in time, not to delay the release. Without the criterion we're not going to be able to keep our 100% HC coverage.

Now, this is really three separate bugs:

1) Not clear to me what's wrong with Rhythmbox. The icons are still present in gnome-themes-standard. Further investigation required.

2) Color Profile Viewer (gnome-color-manager) should probably not be installed by default. I will check with the Workstation folks to make sure it's OK to remove it from comps. Caused by https://git.gnome.org/browse/gnome-color-manager/commit/?id=649c09755bd360d4ed3e40dd4c4e4b120167bac1 where Richard assumed it was not installed by default, so not a gnome-themes-standard issue.

3) For F21 we put the setroubleshoot icon into gnome-themes-standard just to get the release out the door. It's no longer included in gnome-themes-standard (so, not a gnome-themes-standard issue) since we don't want random app icons there (especially apps that are not related to GNOME!). It should be shipped by setroubleshoot. I think Jakub believed it had already been added to setroubleshoot before removing it from gnome-themes-standard; if that's the case, maybe it's not being installed properly.

Comment 3 Michael Catanzaro 2015-03-09 18:32:39 UTC
Hi Jakub. Do you see anything wrong with how Rhythmbox installs its symbolic icon [1]? It looks fine to me. Maybe the shell has gotten confused by the presence of both the symbolic icon and the PNGs in gnome-themes-standard?

[1] https://git.gnome.org/browse/rhythmbox/tree/data/icons/hicolor/scalable/apps/Makefile.am

Comment 4 Adam Williamson 2015-03-09 18:45:11 UTC
"I highly doubt we would slip for an icon polish issue: that would be silly. The point of the criterion IMO is to ensure we remove the offending apps if they're not fixed in time"

Well, those two statements seem to contradict each other.

Removing the 'offending' app is a perfectly reasonable response to a blocker bug 'app X has no high-contrast icon', but it's still treating the bug as a blocker. The question isn't 'how should the blocker bug be resolved', but 'should it be a blocker bug at all'. If you want to slip the release if we haven't fixed *or removed* all apps without high-contrast icons, you still want the criterion to be in place.

Comment 5 Michael Catanzaro 2015-03-11 18:06:12 UTC
Created attachment 1000598 [details]
screenshot of overview (F22 Alpha)

This is much more serious than I thought. I installed F22 Alpha and it looks like we have way bigger problems than rhythmbox -- the entire overview is a mess in high contrast mode. There is a mix of proper HC icons, symbolic icons that were not successfully converted to HC icons, and just a big gray square where Rhythmbox is supposed to be. Rhythmbox gets the gray square for its app menu when high contrast is turned off, too. (We also have a "nice" mix of symbolic and hicolor icons used in the app menu regardless of whether high contrast is turned on, but that is an unrelated issue.)

Clearly the applications are not to blame here: something has gone wrong with the changes in upstream bug 737990 (unless this is an intentional incompatibility, in which case we need a rethink).

P.S. We added NoDisplay=true to Color Profile Viewer for 3.15.92.

Comment 6 Matthias Clasen 2015-03-11 19:08:55 UTC
We will have to live with mix of symbolic and traditional 'hc' icons for a bit. We are transitioning from hc icons (which require black magic to create) to standard symbolic icons (which are much easier to draw). There is no 'conversion' that went wrong.

Comment 7 Michael Catanzaro 2015-03-18 17:17:30 UTC
1) rhythmbox - mysteriously fixed after I ran a system update
2) color profile viewer - "fixed" in 3.15.92 (using NoDisplay=false)
3) setroubleshoot - fix available in bug #1182652

So I think we're good here.


Note You need to log in before you can comment on or make changes to this bug.