Bug 1130794 - Missing high contrast icon
Summary: Missing high contrast icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-themes-standard
Version: 21
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F21FinalBlocker 1175847 1199270
TreeView+ depends on / blocked
 
Reported: 2014-08-17 20:55 UTC by Michael Catanzaro
Modified: 2015-03-05 19:07 UTC (History)
11 users (show)

Fixed In Version: gnome-themes-standard-3.14.2.2-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1175847 (view as bug list)
Environment:
Last Closed: 2014-11-29 21:56:28 UTC


Attachments (Terms of Use)
symbolic icon for SE troubleshooter app, using the current poor naming scheme (3.96 KB, image/svg+xml)
2014-11-20 16:52 UTC, Jakub Steiner
no flags Details
hc rendering of the symbolic icon (20.00 KB, application/x-tar)
2014-11-24 16:27 UTC, Matthias Clasen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1182652 None CLOSED Missing high contrast icon 2019-04-23 16:17:13 UTC

Internal Links: 1182652

Description Michael Catanzaro 2014-08-17 20:55:10 UTC
Description of problem: All applications installed by default in Fedora Workstation should have a high contrast icon. The SELinux Troubleshooter in F20 does not.


Version-Release number of selected component (if applicable): 3.2.17-1.fc20


How reproducible: Always


Steps to Reproduce:
1. Go to System Settings -> Universal Access and turn on High Contrast
2. Go to the overview and look at the apps missing high contrast icons

Actual results: SELinux Troubleshooter displays a hicolor icon


Expected results: SELinux Troubleshooter displays a high contrast icon


Additional info: Andreas Nilsson has made several of these; he might be able to help.

Comment 1 Michael Catanzaro 2014-10-15 00:28:27 UTC
Proposing as a F21 final blocker:

"All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy." [1]

In particular:

"App launchers MUST have a unique[3] 128×128 launcher icon with an alpha channel and a matching High Contrast icon." [2]

The easiest fix is to drop setroubleshoot from the default install, but it might be important enough to actually block the release on....

[1] https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria#Default_application_functionality
[2] https://fedoraproject.org/wiki/Workstation/Guidelines/Applications_and_Launchers#For_launchers:

Comment 2 Miroslav Grepl 2014-10-16 15:27:36 UTC
I gues there should be F21 bug for this issue.

Comment 3 Kamil Páral 2014-11-12 18:03:00 UTC
Discussed at today's blocker review meeting [1]. Accepted as a blocker. This is a pretty clear violation of the criterion: "All applications installed by default in Fedora Workstation must comply with each MUST and MUST NOT guideline in the Applications and Launchers policy.." [2] 

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-12/
[2] https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria#Default_application_functionality

Because this bug was proposed as a blocker, I have hijacked it and switched to F21. Miroslav, if you need a separate bug for F20, please close this. Thanks.

Comment 4 Jaroslav Reznik 2014-11-18 11:20:31 UTC
Icon request: https://fedorahosted.org/design-team/ticket/344

Comment 5 Jakub Steiner 2014-11-20 16:52:07 UTC
Created attachment 959443 [details]
symbolic icon for SE troubleshooter app, using the current poor naming scheme

Bug https://bugzilla.gnome.org/show_bug.cgi?id=740444 currently prevents me from rendering the double stroke PNGs

Comment 6 Adam Williamson 2014-11-22 05:09:49 UTC
Er, symbolic is not the same thing as high contrast, is it?

Comment 7 Michael Catanzaro 2014-11-22 16:08:13 UTC
The symbolic icon can be used to generate a set of high contrast icons using the slightly-broken tool mentioned in comment #5.

Comment 8 Miroslav Grepl 2014-11-24 10:09:04 UTC
So do we need to wait for a fix for #740444?

Comment 9 Jaroslav Reznik 2014-11-24 16:01:12 UTC
(In reply to Jakub Steiner from comment #5)
> Created attachment 959443 [details]
> symbolic icon for SE troubleshooter app, using the current poor naming scheme
> 
> Bug https://bugzilla.gnome.org/show_bug.cgi?id=740444 currently prevents me
> from rendering the double stroke PNGs

Hi Jakub, 
is it possible to create high contrast icon manually? Or do you have any estimate when we can expect fix the tool? This bug was accepted as blocker bug and we will need solution very soon, not to slip/create RC on time (all blockers has to be resolved).

Thanks for help!

Comment 10 Matthias Clasen 2014-11-24 16:27:06 UTC
Created attachment 960862 [details]
hc rendering of the symbolic icon

Comment 11 Matthias Clasen 2014-11-24 16:36:06 UTC
to be clear, those icons should be installed in /usr/share/icons/HighContrast/$size/apps

and run gtk-update-icon-cache in %posttrans / %postun

Comment 12 Adam Williamson 2014-11-25 17:35:20 UTC
mgrepl, could you please build an update with the new icons ASAP? It'd be good to get this off the blocker list. thanks!

Comment 13 Kamil Páral 2014-11-26 11:27:18 UTC
I talked to Miroslav, a new build should be available tomorrow.

Comment 14 Jakub Steiner 2014-11-26 16:41:21 UTC
FWIW gnome-themes-standard-3.14.2.1 includes the properly rendered icon.

Comment 15 Adam Williamson 2014-11-26 18:34:38 UTC
jakub: I think that was maybe meant for https://bugzilla.redhat.com/show_bug.cgi?id=1160499?

Comment 16 Jaroslav Reznik 2014-11-27 09:47:38 UTC
(In reply to Adam Williamson (Red Hat) from comment #15)
> jakub: I think that was maybe meant for
> https://bugzilla.redhat.com/show_bug.cgi?id=1160499?

No, it wasn't. Gnome-themes-standard indeed includes setroubleshoot high contrast icon now (at least 3.15.2-1 in F22 and based on Jakub's comment, also 3.14.2.1). But for F21, the last build is 3.14.2 without setroubleshoot. So we need 3.14.2.1 build for F21.

Comment 17 Jaroslav Reznik 2014-11-27 10:33:54 UTC
So we need someone from desktop team to build the latest 3.14.2.1 package. Upstream tarball contains correct icon.

Comment 18 Jaroslav Reznik 2014-11-27 11:37:11 UTC
Moving to gnome-themes-standard, Kalev is going to build it. Thanks.

Comment 19 Fedora Update System 2014-11-27 17:24:05 UTC
gnome-themes-standard-3.14.2.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gnome-themes-standard-3.14.2.2-1.fc21

Comment 20 Adam Williamson 2014-11-29 01:17:22 UTC
Looks good in Final RC1, high-contrast icon for SELinux Troublesh... in the overview.

Comment 21 Fedora Update System 2014-11-29 21:56:28 UTC
gnome-themes-standard-3.14.2.2-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.