Bug 1199601 - RFE: repoquery support for --pkgnarrow
Summary: RFE: repoquery support for --pkgnarrow
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: rawhide
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1226493 1248797 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-06 17:44 UTC by Jerry James
Modified: 2015-09-23 04:13 UTC (History)
9 users (show)

Fixed In Version: 1.1.1-2.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-09 23:19:13 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1186381 None None None Never

Internal Links: 1186381

Description Jerry James 2015-03-06 17:44:50 UTC
Description of problem:
I'm trying to port some yum-based scripts I use over to dnf and stumbled across the lack of --pkgnarrow support in dnf's version of repoquery.  Please consider adding this.  For example, I use this when I want to search through packages I don't have installed for a particular capability.

The --archlist argument (instead of the existing --arch) is also useful.  That lets me combine searches for, say, x86_64 and noarch packages together without needing to see results for multiarch (i686) packages.

By the way, I'll sneak a tiny typo note in here.  The package description starts with "Core Plugins for DNF. This package enhance DNF with builddep, copr,".  That should be "enhances", not "enhance".

Version-Release number of selected component (if applicable):
dnf-plugins-core-0.1.5-1.fc22.noarch
python3-dnf-plugins-core-0.1.5-1.fc22.noarch

How reproducible:
Always

Steps to Reproduce:
1. This works: repoquery --pkgnarrow=available --archlist=x86_64,noarch '*'
2. This doesn't: dnf repoquery --pkgnarrow=available --arch=x86_64,noarch

Actual results:
Error: unrecognized arguments: --pkgnarrow=available
Also, if the --pkgnarrow argument is omitted, dnf treats the string "x86_64,noarch" as an arch, and hence produces an empty list.  This means that separate queries for x86_64 and noarch are necessary.

Expected results:
Comparable results to the yum-based repoquery's output.

Additional info:

Comment 1 Honza Silhan 2015-03-11 15:19:03 UTC
Thanks for the report. I would prefer to extend `--arch` to accept more than one architecture than implement new switch.

Comment 2 Toshio Ernie Kuratomi 2015-05-21 09:01:12 UTC
Any thoughts on --pkgnarrow?  I found a piece of code that needed it today so that I could run separate queries for installed packages (simulated with raw rpm instead), updates (why I needed pkgnarrow), and anything available.

Comment 3 Honza Silhan 2015-07-14 09:58:24 UTC
Toshio, it's not implemented yet. `--pkgnarrow` switch name seems to me strange. `--updates`, `--installed`, etc. mutually exclusive options would fit better with `dnf list` command.

Comment 4 Honza Silhan 2015-07-21 09:44:57 UTC
* The archlist part is tracked in bug 1186381

Comment 5 Honza Silhan 2015-07-24 09:15:24 UTC
*** Bug 1226493 has been marked as a duplicate of this bug. ***

Comment 6 Honza Silhan 2015-08-28 09:20:02 UTC
*** Bug 1248797 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2015-09-01 09:52:11 UTC
dnf-plugins-core-0.1.11-1.fc23 dnf-1.1.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743

Comment 8 Fedora Update System 2015-09-01 20:22:42 UTC
dnf-1.1.1-1.fc23, dnf-plugins-core-0.1.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf dnf-plugins-core'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743

Comment 9 Fedora Update System 2015-09-08 12:38:33 UTC
dnf-1.1.1-2.fc22 dnf-plugins-core-0.1.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14744

Comment 10 Fedora Update System 2015-09-08 12:38:44 UTC
dnf-1.1.1-2.fc22 dnf-plugins-core-0.1.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14744

Comment 11 Fedora Update System 2015-09-08 12:40:05 UTC
dnf-1.1.1-2.fc23 dnf-plugins-core-0.1.11-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743

Comment 12 Fedora Update System 2015-09-08 17:52:02 UTC
dnf-1.1.1-2.fc23, dnf-plugins-core-0.1.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf dnf-plugins-core'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14743

Comment 13 Fedora Update System 2015-09-08 21:26:06 UTC
dnf-1.1.1-2.fc22, dnf-plugins-core-0.1.11-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf-plugins-core dnf'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14744

Comment 14 Fedora Update System 2015-09-09 23:18:46 UTC
dnf-1.1.1-2.fc22, dnf-plugins-core-0.1.11-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-09-23 04:12:19 UTC
dnf-1.1.1-2.fc23, dnf-plugins-core-0.1.11-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.