Bug 1248797 - dnf repoquery --orphans option
dnf repoquery --orphans option
Status: CLOSED DUPLICATE of bug 1199601
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 16:55 EDT by Andy Wang
Modified: 2015-08-28 05:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-28 05:20:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Wang 2015-07-30 16:55:13 EDT
Description of problem:
dnf list extras outputs orphans in the format:
kernel.x86_64                             4.0.8-300.fc22                 @System
kernel-core.x86_64                        4.0.8-300.fc22                 @System
kernel-debug-devel.x86_64                 4.0.8-300.fc22                 @System
kernel-devel.x86_64                       4.0.8-300.fc22                 @System
kernel-modules.x86_64                     4.0.8-300.fc22                 @System

package-cleanup --orphans lists them in package name format:
kernel-3.10.0-123.13.2.el7.x86_64
kernel-3.10.0-123.20.1.el7.x86_64

package-cleanup --orphans is easily scriptable to a remove call. 

dnf list extras is not.  This is a gap for those of us used to piping the output of package-cleanup --orphans (with some manipulation for excluding manually installed orphans.

Version-Release number of selected component (if applicable):
dnf-1.0.1-2.fc22.noarch
Comment 1 Honza Silhan 2015-08-28 05:20:02 EDT
should be fixed by: https://github.com/rpm-software-management/dnf-plugins-core/commit/c8e61d00689559e63f4902da3d6c0cb05d688e0b

*** This bug has been marked as a duplicate of bug 1199601 ***

Note You need to log in before you can comment on or make changes to this bug.