Bug 119964 - Installer doesn't set up LVM correctly
Summary: Installer doesn't set up LVM correctly
Status: CLOSED DUPLICATE of bug 118787
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-04 08:31 UTC by Per Nystrom
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Per Nystrom 2004-04-04 08:31:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
I tried to install FC2t2, I partitioned using Disk Druid.  I asked for
one LVM group, vg00, on a single disk partition with one volume in it
called home.  On the first boot, it complained "No such file or
directory while trying to open /dev/vg00/home" when it tried to fsck
it and dropped me to single user maintenance.  lvm vgdisplay shows me
that vg00 was created, but the directory /dev/vg00 doesn't exist and I
get stuff like "/dev/mapper/control: open failed: No such file or
directory"

For someone who's used to dealing with it, this stuff is easy enough
to set up by hand after installing.  LVM/RAID support in the installer
(Disk Druid?) has had weird quirks like this for a long time.  I
remember the installer would just crash if I tried to set up RAID in
RHL 9, and there was something in RHL 8 also, but I don't remember
exactly what it was.  Maybe it's time to fix it or take LVM/RAID
options out of the installer?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Install using LVM.  Create at least one volume group and one volume
inside it.


Actual Results:  Unbootable system (could not find/fsck the logical
volume(s)).

Expected Results:  Bootable system.

Additional info:

Comment 1 Ronny Buchmann 2004-04-04 09:31:28 UTC
I had the same problem.

Solution was as follows (at "repair filesystem" stage):

 - modprobe dm-mod
 - echo "mkdmnod" | nash
 - restorecon /dev/mapper/control
 - lvm vgscan
 (this has exited with code 5, why?)

 - lvm vgchange -a y
 - mount -a
 - exit

after the second reboot everything went fine automatically

Comment 2 Ronny Buchmann 2004-04-04 10:15:24 UTC
this is a duplicate of bug 118787

Comment 3 Jeremy Katz 2004-04-05 22:25:54 UTC

*** This bug has been marked as a duplicate of 118787 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:02:24 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.