Bug 118787 - Special devices for LVM are not created.
Special devices for LVM are not created.
Status: CLOSED DUPLICATE of bug 119975
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 119964 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-20 06:27 EST by Frederic Soulier
Modified: 2007-04-18 13:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frederic Soulier 2004-03-20 06:27:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030630

Description of problem:
- Installation on a blank hard drive (/dev/hdg, 80Gb) connected to a
Promise Ultra100TX2.
- Created partitions using fdisk prior to running FC2 Test1
installtion procedure (reason, xref bug #118785,
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118785)

/boot     /dev/hdg1   primary             80Mb
          /dev/hdg4   extended      (all disk)
    SWAP      /dev/hdg5   logical       1024Mb
    /         /dev/hdg6   logical        300Mb
    LVM PV    /dev/hdg7   logical      55000Mb

- Installation booted with "linux xfs"
- creation of partitions within vg01 as follows
- filesystems selected as follows

/boot     /dev/hdg1   primary             80Mb     ext2
          /dev/hdg4   extended      (all disk)
    SWAP      /dev/hdg5   logical       1024Mb     swap
    /         /dev/hdg6   logical        300Mb     ext3
    LVM PV    /dev/hdg7   logical      55000Mb
        /usr     /dev/vg01/usrlv       14000Mb     xfs
        /home    /dev/vg01/homelv      15000Mb     xfs
        /opt     /dev/vg01/optlv        5000Mb     xfs
        /var     /dev/vg01/varlv        5000Mb     xfs
        /tmp     /dev/vg01/tmplv        1000Mb     xfs
        /vmware  /dev/vg01/vmwarelv    12000Mb     xfs

- Installation when fine.
- Upon reboot I get:

fsck: cannot check /dev/vg01/homelv: fsck.xfs not found
fsck: cannot check /dev/vg01/usrlv: fsck.xfs not found
fsck: cannot check /dev/vg01/optlv: fsck.xfs not found
fsck: cannot check /dev/vg01/varlv: fsck.xfs not found
fsck: cannot check /dev/vg01/tmplv: fsck.xfs not found
fsck: cannot check /dev/vg01/vmwarelv: fsck.xfs not found

then

Mounting local filesystems:
mount: special device /dev/vg01/homelv does not exist
mount: special device /dev/vg01/usrlv does not exist
mount: special device /dev/vg01/optlv does not exist
mount: special device /dev/vg01/varlv does not exist
mount: special device /dev/vg01/tmplv does not exist
mount: special device /dev/vg01/vmwarelv does not exist

followed by loads of error because files can't be found.

I know the XFS filesystem is not *officially* supported but the
special devices for the VG should still be created.

Note: same thing with LVM and ReiserFS (instead of XFS).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. LVM with XFS formatted (or ReiserFS) formatted partitions
2.
3.
    

Actual Results:  Special devices for LVM /dev/vg01/ not created

Expected Results:  Special devices for LVM should be created.

Additional info:
Comment 1 Jeremy Katz 2004-03-22 00:50:04 EST
But it works with ext3?  I can't think of any fs specific code here
and was doing lvm installs without any trouble on Friday...
Comment 2 Frederic Soulier 2004-03-22 16:17:46 EST
I'm going to try with ext3 and see if I get the same pbm as I had with
ReiserFs and XFS.
Comment 3 Frederic Soulier 2004-03-22 17:41:55 EST
Ok just tried with ext3 (booting by just hitting enter). It installs
fine as with ReiserFS and Xfs then upon reboot I get:

fsck.ext3: No such file or directory while trying to open /dev/vg01/usrlv
/dev/vg01/usrlv:
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the
superblock is corrupt, and you might try running e2fsck with an
alternate superblock: e2fsck -b 8193 <device>

Same thing Repeated for:
   /dev/vg01/homelv
   /dev/vg01/optlv
   /dev/vg01/varlv
   /dev/vg01/tmplv
   /dev/vg01/vmwarelv

I then have the option to enter my root password to get into the
maintenance mode. OK entered the maintenance mode. Tried to list ls
-la /dev/vg* and nothing...

So I now have a situation where I cannot use LVM neither with xfs,
reiserfs nor with ext3...
Comment 4 Jeremy Katz 2004-04-05 18:25:57 EDT
*** Bug 119964 has been marked as a duplicate of this bug. ***
Comment 5 Ronny Buchmann 2004-04-06 12:49:14 EDT
More details and possible resolution in bug 119975.

Maybe close as duplicate.
Comment 6 Dave Johnson 2004-04-06 14:59:06 EDT
Also--
We found the initial /dev/mapper mknod script not in lvm2 rpm, also
these files do not get created with a lvm2 install.  We did a "linux
rescue" from cd and copied these files over, now the system boots up.

Comment 7 Jeremy Katz 2004-05-06 17:43:32 EDT

*** This bug has been marked as a duplicate of 119975 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:02:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.