Bug 1200559 - [abrt] totem: browse_cb(): totem killed by SIGABRT
Summary: [abrt] totem: browse_cb(): totem killed by SIGABRT
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: grilo-plugins
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:de0be700ad6496b78c741593c70...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-10 20:33 UTC by Mikhail
Modified: 2015-08-31 02:14 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-06 20:21:57 UTC


Attachments (Terms of Use)
File: backtrace (94.25 KB, text/plain)
2015-03-10 20:33 UTC, Mikhail
no flags Details
File: cgroup (190 bytes, text/plain)
2015-03-10 20:33 UTC, Mikhail
no flags Details
File: core_backtrace (59.94 KB, text/plain)
2015-03-10 20:34 UTC, Mikhail
no flags Details
File: dso_list (26.46 KB, text/plain)
2015-03-10 20:34 UTC, Mikhail
no flags Details
File: environ (1.00 KB, text/plain)
2015-03-10 20:34 UTC, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2015-03-10 20:34 UTC, Mikhail
no flags Details
File: maps (128.21 KB, text/plain)
2015-03-10 20:34 UTC, Mikhail
no flags Details
File: open_fds (2.75 KB, text/plain)
2015-03-10 20:34 UTC, Mikhail
no flags Details
File: proc_pid_status (953 bytes, text/plain)
2015-03-10 20:34 UTC, Mikhail
no flags Details
File: var_log_messages (7.66 KB, text/plain)
2015-03-10 20:34 UTC, Mikhail
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 730028 None None None Never
Red Hat Bugzilla 1206960 None None None Never

Internal Links: 1206960

Description Mikhail 2015-03-10 20:33:52 UTC
Version-Release number of selected component:
totem-3.15.91-1.fc22

Additional info:
reporter:       libreport-2.4.0
backtrace_rating: 4
cmdline:        /usr/bin/totem --gapplication-service
crash_function: browse_cb
executable:     /usr/bin/totem
kernel:         4.0.0-0.rc2.git0.1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (4 frames)
 #4 browse_cb at totem-grilo.c:694
 #5 queue_process at grl-source.c:2089
 #9 g_main_context_iteration at gmain.c:3869
 #10 g_application_run at gapplication.c:2308

Potential duplicate: bug 1171390

Comment 1 Mikhail 2015-03-10 20:33:57 UTC
Created attachment 1000141 [details]
File: backtrace

Comment 2 Mikhail 2015-03-10 20:33:58 UTC
Created attachment 1000142 [details]
File: cgroup

Comment 3 Mikhail 2015-03-10 20:34:01 UTC
Created attachment 1000143 [details]
File: core_backtrace

Comment 4 Mikhail 2015-03-10 20:34:02 UTC
Created attachment 1000144 [details]
File: dso_list

Comment 5 Mikhail 2015-03-10 20:34:07 UTC
Created attachment 1000147 [details]
File: environ

Comment 6 Mikhail 2015-03-10 20:34:08 UTC
Created attachment 1000149 [details]
File: limits

Comment 7 Mikhail 2015-03-10 20:34:10 UTC
Created attachment 1000150 [details]
File: maps

Comment 8 Mikhail 2015-03-10 20:34:12 UTC
Created attachment 1000151 [details]
File: open_fds

Comment 9 Mikhail 2015-03-10 20:34:13 UTC
Created attachment 1000153 [details]
File: proc_pid_status

Comment 10 Mikhail 2015-03-10 20:34:14 UTC
Created attachment 1000154 [details]
File: var_log_messages

Comment 11 Mikhail 2015-03-13 05:31:38 UTC
Occurs when I try find codec in Software.

Comment 12 Petr Schindler 2015-04-16 09:03:21 UTC
This happens I run totem without any other parameter from console or try to run it from Activities. When I run totem with some video as argument it runs correctly (even though it segfaults after it's closed).

I tested this with clean installation of F22 Workstation Live Beta RC3.

I propose this as final blocker because it violates final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

Comment 13 Petr Schindler 2015-04-20 18:53:33 UTC
Discussed at today's blocker review meeting [1].

This bug was accepted as Final Blocker - clear violation of criterion "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-20/

Comment 14 David Gay 2015-04-28 23:11:54 UTC
Discussed at the 2015-04-28 blocker review meeting.[1]

Bastien, any news on this?

[1]: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-28/

Comment 15 Bastien Nocera 2015-04-29 08:40:45 UTC
It's a known bug in Tracker, offering audio files as videos. It's existed in Fedora 21 as well, and the crash is dependent on the user's files.

See the upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=730028

Comment 16 Adam Williamson 2015-04-30 23:59:36 UTC
Please do not close release blocker bugs without actually fixing the bug, it messes up tracking. Release blocker bugs *must* remain open until fixed.

It is 'dependent on the user's files' indeed, but multiple testers (including myself) have confirmed that on F22, one 'user files' configuration that triggers the bug is *no* files (or, 'whatever files are there out of the box') - if you do a clean install of F22 and try to launch totem, it crashes.

Comment 17 Bastien Nocera 2015-05-06 14:00:39 UTC
(In reply to Adam Williamson from comment #16)
> if you do a clean install of F22 and try to launch
> totem, it crashes.

It doesn't using the current Beta (Beta 3, from Fedora-Live-Workstation-x86_64-22_Beta-3.iso).

https://bugzilla.gnome.org/show_bug.cgi?id=730028#c19 contains a command to run to unbreak it. I don't plan on making any changes related to this, as the bug has existed in grilo-plugins' Tracker plugin for 3 GNOME releases, and 1 (very soon 2) Fedora releases.

Better remove it from the blockers.

Comment 18 Michal Srb 2015-05-06 18:43:30 UTC
I can reproduce this as well. I am running F22 with latest updates from updates-testing, originally installed from Fedora-Live-Workstation-x86_64-22_Beta-3.iso.

$ tracker sparql -q "SELECT  ?url WHERE { ?x a nfo:Video . ?x a nfo:Image . ?x nie:url ?url }"
Results:
  None

$ totem

(totem:2294): GLib-GObject-WARNING **: The property GtkCellRendererPixbuf:follow-state is deprecated and shouldn't be used anymore. It will be removed in a future version.

... <snip> ...

(totem:2294): GLib-GObject-WARNING **: The property SoupSession:ssl-ca-file is deprecated and shouldn't be used anymore. It will be removed in a future version.

(totem:2294): Gdk-ERROR **: The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 694 error_code 8 request_code 72 (core protocol) minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)

Comment 19 Adam Williamson 2015-05-06 20:21:57 UTC
It looks like abrt has been messing with us here. The 'dupes' of this bug from testers running clean installs are likely not the same as the original bug at all: that BadMatch error is something different.

Running totem or Maps from a fresh live instance in a KVM or with LIBGL_ALWAYS_SOFTWARE=1 seems to always crash with a BadMatch error; with hardware accel it works. I've repurposed https://bugzilla.redhat.com/show_bug.cgi?id=1206960 to cover that.  This one we can set back to CLOSED UPSTREAM and remove as a blocker.


Note You need to log in before you can comment on or make changes to this bug.