Bug 1206960 - Various apps crash with an X BadMatch error when run on GNOME with llvmpipe
Summary: Various apps crash with an X BadMatch error when run on GNOME with llvmpipe
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clutter
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: AcceptedBlocker abrt_hash:6b6792aeb7...
: 1221715 (view as bug list)
Depends On:
Blocks: F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-03-30 00:27 UTC by Wallace Hermano
Modified: 2015-07-31 12:12 UTC (History)
23 users (show)

Fixed In Version: clutter-1.22.0-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-11 19:06:35 UTC


Attachments (Terms of Use)
File: backtrace (99.04 KB, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: cgroup (190 bytes, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: core_backtrace (46.29 KB, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: dso_list (26.91 KB, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: environ (903 bytes, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: limits (1.29 KB, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: maps (113.89 KB, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: mountinfo (3.44 KB, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: namespaces (85 bytes, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: open_fds (1.19 KB, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details
File: proc_pid_status (958 bytes, text/plain)
2015-03-30 00:27 UTC, Wallace Hermano
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 90354 None None None Never
Red Hat Bugzilla 1200559 None None None Never

Internal Links: 1200559

Description Wallace Hermano 2015-03-30 00:27:30 UTC
Version-Release number of selected component:
gjs-1.43.3-1.fc22

Additional info:
reporter:       libreport-2.5.0
backtrace_rating: 4
cmdline:        /usr/bin/gjs /usr/share/gnome-maps/org.gnome.Maps --gapplication-service
crash_function: _g_log_abort
executable:     /usr/bin/gjs-console
global_pid:     2380
kernel:         4.0.0-0.rc5.git1.3.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000
var_log_messages: [System Logs]:\n-- Logs begin at Dom 2015-03-29 20:25:04 BRT, end at Dom 2015-03-29 21:16:42 BRT. --

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 _g_log_abort at gmessages.c:315
 #8 _XEventsQueued at xcb_io.c:364
 #9 XEventsQueued at Pending.c:43
 #10 _cairo_xlib_shm_info_cleanup at cairo-xlib-surface-shm.c:481
 #11 _cairo_xlib_shm_info_create at cairo-xlib-surface-shm.c:640
 #12 _cairo_xlib_shm_surface_create at cairo-xlib-surface-shm.c:829
 #13 _cairo_xlib_surface_create_shm at cairo-xlib-surface-shm.c:1155
 #14 _cairo_xlib_surface_create_similar_shm at cairo-xlib-surface-shm.c:1180
 #15 INT_cairo_surface_create_similar_image at cairo-surface.c:593
 #16 gdk_window_create_similar_image_surface at gdkwindow.c:9563

Comment 1 Wallace Hermano 2015-03-30 00:27:36 UTC
Created attachment 1008107 [details]
File: backtrace

Comment 2 Wallace Hermano 2015-03-30 00:27:37 UTC
Created attachment 1008108 [details]
File: cgroup

Comment 3 Wallace Hermano 2015-03-30 00:27:39 UTC
Created attachment 1008109 [details]
File: core_backtrace

Comment 4 Wallace Hermano 2015-03-30 00:27:42 UTC
Created attachment 1008110 [details]
File: dso_list

Comment 5 Wallace Hermano 2015-03-30 00:27:43 UTC
Created attachment 1008111 [details]
File: environ

Comment 6 Wallace Hermano 2015-03-30 00:27:45 UTC
Created attachment 1008112 [details]
File: limits

Comment 7 Wallace Hermano 2015-03-30 00:27:52 UTC
Created attachment 1008113 [details]
File: maps

Comment 8 Wallace Hermano 2015-03-30 00:27:53 UTC
Created attachment 1008114 [details]
File: mountinfo

Comment 9 Wallace Hermano 2015-03-30 00:27:55 UTC
Created attachment 1008115 [details]
File: namespaces

Comment 10 Wallace Hermano 2015-03-30 00:27:56 UTC
Created attachment 1008116 [details]
File: open_fds

Comment 11 Wallace Hermano 2015-03-30 00:27:58 UTC
Created attachment 1008117 [details]
File: proc_pid_status

Comment 12 Jonathan Haas 2015-04-19 13:20:41 UTC
Another user experienced a similar problem:

Can be reproduced reliably in a relatively fresh Fedora 22 installation. Happens everytime I start the "Maps" activity. Not running a Wayland session.

reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        /usr/bin/gjs /usr/share/gnome-maps/org.gnome.Maps --gapplication-service
crash_function: _g_log_abort
executable:     /usr/bin/gjs-console
global_pid:     32003
kernel:         4.0.0-0.rc5.git4.1.fc22.x86_64
package:        gjs-1.43.3-1.fc22
reason:         gjs-console killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 Adam Williamson 2015-05-06 01:09:37 UTC
Another user experienced a similar problem:

Occurs on launch of Maps from a clean install of Fedora 22 Final TC1 Workstation live x86_64.

reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        /usr/bin/gjs /usr/share/gnome-maps/org.gnome.Maps --gapplication-service
crash_function: _g_log_abort
executable:     /usr/bin/gjs-console
global_pid:     5597
kernel:         4.0.0-1.fc22.x86_64
package:        gjs-1.43.3-1.fc22
reason:         gjs-console killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Adam Williamson 2015-05-06 01:17:40 UTC
Proposed Final blocker: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." - https://fedoraproject.org/wiki/Fedora_22_Final_Release_Criteria#Default_application_functionality

Comment 15 Adam Williamson 2015-05-06 20:19:10 UTC
OK, so this and the recent cases of https://bugzilla.redhat.com/show_bug.cgi?id=1200559 are all likely the same bug, and the bug is this: when you run the app with llvmpipe, it crashes with an X BadMatch error.

You can reproduce this by running them in a KVM, on a metal system with no hardware acceleration, or on a system *with* acceleration like this:

LIBGL_ALWAYS_SOFTWARE=1 totem
LIBGL_ALWAYS_SOFTWARE=1 gnome-maps

I've confirmed both totem and Maps are affected on a clean boot of Final TC2 Workstation x86_64 live - no need to install, it can be reproduced right from the live environment. https://dl.fedoraproject.org/pub/alt/stage/22_TC2/Workstation/x86_64/iso/Fedora-Live-Workstation-x86_64-22-TC2.iso

drago01 said file against mesa, so moving to that.

Comment 16 Igor Gnatenko 2015-05-06 22:26:02 UTC
Reported in upstream.

https://bugs.freedesktop.org/show_bug.cgi?id=90354

Comment 17 Michael Catanzaro 2015-05-06 22:58:51 UTC
I think we can go ahead and mark this as accepted blocker, since bug #1200559 was previously accepted blocker. Moving the blocker status from that bug to this one is just Bugzilla wrangling and shouldn't require a formal meeting.

Comment 18 Adam Williamson 2015-05-06 23:05:10 UTC
Actually I'd rather re-discuss it, because the situation has changed a bit. That one was approved on the belief that it *always happened*, but in fact it only happens when hardware acceleration isn't available, so it's not quite the same situation we discussed.

Comment 19 Adam Williamson 2015-05-06 23:38:13 UTC
Also affects Cheese, I believe.

Comment 20 Dave Airlie 2015-05-07 02:07:23 UTC
Looks like some disagreement between a 32-bit depth and 24-bit depth somewhere,
so this might not be a mesa bug, bug a cogl/clutter bug.

Basically swrast is trying to putimage a 24 depth/ 32 bpp image to a 32/32 drawable.

Comment 21 Dave Airlie 2015-05-07 02:27:46 UTC
I've debugged this a big, pretty sure its a cogl/clutter/gtk bug,

a 32-bit window gets created, then cogl creates a 24-bit glX

#0  0x000000302bc410d0 in XCreateWindow (dpy=dpy@entry=0x87fc00, parent=parent@entry=31457314, x=-1, y=46, width=1, height=1, borderWidth=0, depth=32, class=1, visual=0x87f3c0, valuemask=8218, attributes=0x7fffffff7da0) at Window.c:113
#1  0x0000003d3b8698e5 in _gdk_x11_display_create_window_impl (display=0x890000 [GdkX11Display], window=0xf55e70 [GdkX11Window], real_parent=<optimized out>, screen=0x896020 [GdkX11Screen], event_mask=14827270, attributes=0x0, attributes_mask=0) at gdkwindow-x11.c:1101
#2  0x0000003d3b842d3d in gdk_window_ensure_native (window=0xf55e70 [GdkX11Window]) at gdkwindow.c:1756
#3  0x0000003d3f244130 in clutter_stage_gdk_realize (stage_window=0xc2d190) at gdk/clutter-stage-gdk.c:267
#4  0x0000003d3f2ae58c in clutter_stage_realize (self=0xc63210 [ClutterStage]) at clutter-stage.c:746
#5  0x000000302a40fe74 in _g_closure_invoke_va (closure=closure@entry=0x612440, return_value=return_value@entry=0x0, instance=instance@entry=0xc63210, args=args@entry=0x7fffffff8180, n_params=<optimized out>, param_types=0x0) at gclosure.c:831

XID 0x1e000ec

#0  0x00007ffff7b25279 in XCreateDrawable (pdp=0xcfa3e0, dpy=0x87fc00, drawable=31457516, visualid=537) at drisw_glx.c:60
#1  0x00007ffff7b25f09 in driswCreateDrawable (base=0x913b10, xDrawable=31457516, drawable=31457517, modes=0x9e8200) at drisw_glx.c:516
#2  0x00007ffff7af458a in CreateDRIDrawable (dpy=0x87fc00, config=0x9e8200, drawable=31457516, glxdrawable=31457517, attrib_list=0x0, num_attribs=0) at glx_pbuffer.c:209
#3  0x00007ffff7af4e34 in CreateDrawable (dpy=0x87fc00, config=0x9e8200, drawable=31457516, attrib_list=0x0, glxCode=31 '\037') at glx_pbuffer.c:492
#4  0x00007ffff7af5759 in glXCreateWindow (dpy=0x87fc00, config=0x9e8200, win=31457516, attrib_list=0x0) at glx_pbuffer.c:967
#5  0x0000003d4266d752 in _cogl_winsys_onscreen_init (onscreen=0xfc55d0, error=0x7fffffff7e90) at winsys/cogl-winsys-glx.c:1421
#6  0x0000003d4265a8de in cogl_framebuffer_allocate (framebuffer=0xfc55d0, error=error@entry=0x7fffffff7e90) at ./cogl-framebuffer.c:750

cogl asks for visual 537 which is 24-bit.

So not mesa bug from what I can see.

Comment 22 Dave Airlie 2015-05-07 02:30:17 UTC
reassign to gtk for now

Comment 23 Matthias Clasen 2015-05-07 12:51:22 UTC
Upstream clutter fix here: https://git.gnome.org/browse/clutter/commit/?id=8fc8a73580ceb810ee7f34eae0df26fac4cb277d

Comment 24 Fedora Update System 2015-05-07 13:39:47 UTC
clutter-1.22.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/clutter-1.22.0-2.fc22

Comment 25 Adam Williamson 2015-05-08 21:16:08 UTC
Fix confirmed in TC3.

Comment 26 Fedora Update System 2015-05-11 19:06:35 UTC
clutter-1.22.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Dan Mossor [danofsatx] 2015-05-11 19:41:30 UTC
Discussed at the 2015-05-11 blocker review meeting[0]. Voted as AcceptedBlocker.

#agreed 1206960 - AcceptedBlocker - violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test" if hardware acceleration isn't available

[0]: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-11/

Comment 28 Adam Williamson 2015-05-11 20:33:36 UTC
Correcting erroneous resolution change.

Comment 29 Igor Gnatenko 2015-05-14 17:37:33 UTC
*** Bug 1221715 has been marked as a duplicate of this bug. ***

Comment 30 rh 2015-06-04 11:50:04 UTC
(In reply to Fedora Update System from comment #26)
> clutter-1.22.0-2.fc22 has been pushed to the Fedora 22 stable repository. 
> If problems still persist, please make note of it in this bug report.

totem and maps still crash here with clutter-1.22.2-2.fc22.x86_64

Do you need further information?

Comment 31 Sergio Monteiro Basto 2015-06-06 18:27:53 UTC
totem still crash for me too, we got bug #1206027 opened since 23 March, 2015

Comment 32 rh 2015-07-31 12:12:57 UTC
Today was an update to

clutter-gtk-1.6.2-1.fc22.x86_64
clutter-gst2-2.0.14-2.fc22.x86_64
clutter-gst3-3.0.8-1.fc22.x86_64
clutter-1.22.4-1.fc22.x86_64
xorg-x11-drv-nvidia-352.30-1.fc22.x86_64
kmod-nvidia-4.1.3-200.fc22.x86_64-352.30-2.fc22.x86_64

and now Maps and totem crash again…


Note You need to log in before you can comment on or make changes to this bug.