Bug 12009 - rpm -F with ftp://...
rpm -F with ftp://...
Status: CLOSED DUPLICATE of bug 20607
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-09 00:32 EDT by kribs
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-14 13:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kribs 2000-06-09 00:32:20 EDT
Using rpm-3.0.4-0.48, I find that, say,

rpm -F "ftp://mirrorsite.mirror/..../redhat-updates/6.2/i386/netscape*.rpm"

copies all netscape files into /var/tmp, and proceeds to install
all (three) netscape rpm packages regardless of what is currently 
installed.  For example, I don't have communicator installed, yet
the above proceeded to install it.  However, if I ftp all of these 
netscape packages to /tmp and run

rpm -F /tmp/netscape*.rpm

then only those pieces of netscape currently installed are 
upgraded (i.e., correct `freshen' behavior).

Is there a fix?

Thanks,
      - Graham
Comment 1 Jeff Johnson 2000-07-31 13:01:34 EDT
Rpm insulates itself from network indeterminancy by downlaoding the entire
package before
checking (and in the -F case, discarding) if the package should be installed. At
the
moment this is a "feature", not a bug (although I understand perfectly why you
wish
the behavior changed.)
Comment 2 Jeff Johnson 2001-01-09 11:29:44 EST

*** This bug has been marked as a duplicate of 20607 ***

Note You need to log in before you can comment on or make changes to this bug.