Bug 20607 - freshen using an ftp url doesn't check versioning before retrieving
freshen using an ftp url doesn't check versioning before retrieving
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
: 12009 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-09 18:25 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 11:29:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-09 18:25:38 EST
The freshen command, when used in conjunction with an ftp url, isn't very
smart about versioning. It will retrieve the file BEFORE checking whether
it is more recent than the current version--or even whether any version is
installed at all--resulting in a tremendous amount of overhead.

For example:

	rpm -Fvh
ftp://ftp.freesoftware.com/.1/linux/redhat/current/updates/i386/*rpm

retrieves all files in the directory before even checking to see if a
current version is installed.
Comment 1 Jeff Johnson 2001-01-09 11:29:30 EST
*** Bug 12009 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Johnson 2001-12-19 14:56:40 EST
Yes, rpm retrieves all files before installing. This is the
mannaer in which rpm was designed. No, it's not possible
to use the file name to extract versions, the header contains
version inormation. The entire package is downloaded to
eliminate possible network corruption.

Note You need to log in before you can comment on or make changes to this bug.