Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1201285 - [rgmanager] unused shutdown_wait in postgres-8.metadata
Summary: [rgmanager] unused shutdown_wait in postgres-8.metadata
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents
Version: 6.7
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 6.8
Assignee: Fabio Massimo Di Nitto
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 13:12 UTC by Patrik Hagara
Modified: 2015-09-10 06:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1208647 (view as bug list)
Environment:
Last Closed: 2015-09-10 06:17:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 694816 0 low CLOSED postgres-8 resource agent does not detect a failed start of postgres server 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 917781 0 low CLOSED luci should make it explicit that "shutdown_wait" is being ignored at postgres-8 since 6.2 2021-02-22 00:41:40 UTC

Internal Links: 694816 917781

Description Patrik Hagara 2015-03-12 13:12:53 UTC
Description of problem:
shutdown_wait option of cman Postgres-8 RA is ignored by clufter while it could be converted to "stop" option in pcs.

Version-Release number of selected component (if applicable):
6653eb19834b66b3dde4dafc1e4533e4a00df748 from next branch

How reproducible:
always

Steps to Reproduce:
1. try converting cluster.conf containing postgres-8 resource with defined shutdown_wait timeout

Actual results:
ignored

Expected results:
should be migrated to "stop"

Additional info:
none

Comment 1 Jan Pokorný [poki] 2015-03-12 14:57:26 UTC
If I am not mistaken this is actually a bug in resource-agents:
https://github.com/ClusterLabs/resource-agents/pull/584
and hence intentionally omitted in the conversion
(as that parameter had actually no effect in the past).

Comment 2 Jan Pokorný [poki] 2015-03-12 14:58:33 UTC
Alternatively give that parameter a meaning and then it would be
a bug in the conversion/clufter.

Comment 4 Jan Pokorný [poki] 2015-04-01 16:17:58 UTC
This discrepancy introduced with
https://github.com/ClusterLabs/resource-agents/commit/5e026d222796c4a898b9e157c4a90ac15b0206d9
([bug 694816])


Note You need to log in before you can comment on or make changes to this bug.