Bug 1201469 - Review Request: gegl03 - Graph based image processing framework
Summary: Review Request: gegl03 - Graph based image processing framework
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-12 18:24 UTC by Kalev Lember
Modified: 2015-03-13 19:36 UTC (History)
3 users (show)

Fixed In Version: gegl03-0.3.0-0.3.gitc9bbc81.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-13 19:36:57 UTC
Type: ---
debarshir: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Kalev Lember 2015-03-12 18:24:10 UTC
Spec URL: https://kalev.fedorapeople.org/gegl03.spec
SRPM URL: https://kalev.fedorapeople.org/gegl03-0.3.0-0.1.git06aea8e.fc22.src.rpm
Description:
GEGL (Generic Graphics Library) is a graph based image processing framework.
GEGLs original design was made to scratch GIMPs itches for a new
compositing and processing core. This core is being designed to have
minimal dependencies. and a simple well defined API.

Fedora Account System Username: kalev

Note that this package is parallel installable with the "gegl" package with API version 0.2. The newer 0.3 API is required for latest gnome-music.

Also note that it doesn't currently build on arm. Patch posted in https://bugzilla.gnome.org/show_bug.cgi?id=746103

Comment 1 Kalev Lember 2015-03-12 18:25:25 UTC
koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=9211479

Comment 2 Kalev Lember 2015-03-13 15:09:30 UTC
* Fri Mar 13 2015 Kalev Lember <kalevlember@gmail.com> - 0.3.0-0.2.gitc9bbc81
- Update to latest git master, fixing the build on arm

Spec URL: https://kalev.fedorapeople.org/gegl03.spec
SRPM URL: https://kalev.fedorapeople.org/gegl03-0.3.0-0.2.gitc9bbc81.fc22.src.rpm

Comment 3 Debarshi Ray 2015-03-13 15:36:37 UTC
MUST items
----------

rpmlint output:

$ rpmlint gegl03-0.3.0-0.1.git06aea8e.fc22.src.rpm 
gegl03.src: W: spelling-error %description -l en_US compositing -> composting, com positing, com-positing
gegl03.src: W: invalid-url Source0: gegl-0.3.0-06aea8e.tar.bz2
1 packages and 0 specfiles checked; 0 errors, 2 warnings.

$ rpmlint gegl03-0.3.0-0.1.git06aea8e.fc21.x86_64.rpm
gegl03.x86_64: W: spelling-error %description -l en_US compositing -> composting, com positing, com-positing
gegl03.x86_64: W: no-documentation
1 packages and 0 specfiles checked; 0 errors, 2 warnings.

$ rpmlint gegl03-debuginfo-0.3.0-0.1.git06aea8e.fc21.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

$ rpmlint gegl03-devel-0.3.0-0.1.git06aea8e.fc21.x86_64.rpm
gegl03-devel.x86_64: W: only-non-binary-in-usr-lib
gegl03-devel.x86_64: W: no-documentation
gegl03-devel.x86_64: E: zero-length /usr/share/vala/vapi/gegl-0.3.deps
1 packages and 0 specfiles checked; 1 errors, 2 warnings.

All those are harmless, except the one about the zero length VAPI file. Maybe we should build with --without-vala ?

YES - package follows Naming Guidelines
YES - spec file name matches base package %{name}

YES - package follows Packaging Guidelines

    Some minor grammatical errors in %description. "GIMPs itches" should be "GIMP's itches", "minimal dependencies. and a" should be "minimal dependencies and a".

    There should be a Requires on ImageMagick. operations/common/magick-load.c has a fallback image loader which uses convert(1).

We should probably fix these in gegl (the 0.2.x package) also.

YES - package is under a Fedora approved license
YES - license field matches actual license
YES - source package includes license text, which is included in %license
YES - spec file written in American English
YES - spec file is legible

YES - sources match upstream source
    Since this is a Git snapshot, the checksum of the tarball depends on the exact versions of Autotools.

YES - package compiles on all primary architectures
YES - there is no need for ExcludeArch
YES - all build dependencies in BuildRequires
YES - handles locales properly
YES - calls ldconfig in %post and %postun
YES - doesn't bundle system libraries
YES - package is not relocatable
YES - package owns all directories that it creates
YES - files are listed only once in %files
YES - file permissions are set properly
YES - consistent use of macros
YES - package contains code or permissible content
YES - no need for doc subpackage
YES - no chance of items marked as %doc affecting runtime
YES - no static libraries
YES - development files in devel subpackage
YES - devel subpackage requires base package
YES - package removes all libtool archives
YES - package doesn't need a .desktop file
YES - doesn't own files or directories owned by other packages
YES - all filenames are valid UTF-8

SHOULD items
------------

YES - package includes license text from upstream
NO  - description and summary doesn't have translations
YES - package builds in Koji
YES - builds on all primary architectures
YES - package functions as described
YES - package doesn't use scriptlets
YES - no subpackages other than devel
YES - pkgconfig files are part of devel subpackage
YES - no dependencies outside of /etc/, /bin/, /sbin, etc.
YES - no need for man pages

Comment 4 Kalev Lember 2015-03-13 15:58:18 UTC
(In reply to Debarshi Ray from comment #3)
> gegl03-devel.x86_64: E: zero-length /usr/share/vala/vapi/gegl-0.3.deps
> 1 packages and 0 specfiles checked; 1 errors, 2 warnings.
> 
> All those are harmless, except the one about the zero length VAPI file.
> Maybe we should build with --without-vala ?

It's just the .deps file that's zero length, the vapi file seems fine. I think it's harmless, but would be nice to fix it upstream by not including the empty .deps file.

>     Some minor grammatical errors in %description. "GIMPs itches" should be
> "GIMP's itches", "minimal dependencies. and a" should be "minimal
> dependencies and a".

Fixed both.
 

>     There should be a Requires on ImageMagick.
> operations/common/magick-load.c has a fallback image loader which uses
> convert(1).

Done.


* Fri Mar 13 2015 Kalev Lember <kalevlember@gmail.com> - 0.3.0-0.3.gitc9bbc81
- Package review fixes (#1201469)
- Fix grammar errors in package description
- Add a runtime dep on /usr/bin/convert

Spec URL: https://kalev.fedorapeople.org/gegl03.spec
SRPM URL: https://kalev.fedorapeople.org/gegl03-0.3.0-0.3.gitc9bbc81.fc22.src.rpm

Comment 5 Debarshi Ray 2015-03-13 16:08:57 UTC
(In reply to Kalev Lember from comment #4)
> (In reply to Debarshi Ray from comment #3)
> > gegl03-devel.x86_64: E: zero-length /usr/share/vala/vapi/gegl-0.3.deps
> > 1 packages and 0 specfiles checked; 1 errors, 2 warnings.
> > 
> > All those are harmless, except the one about the zero length VAPI file.
> > Maybe we should build with --without-vala ?
> 
> It's just the .deps file that's zero length, the vapi file seems fine. I
> think it's harmless, but would be nice to fix it upstream by not including
> the empty .deps file.

Ok.

> >     Some minor grammatical errors in %description. "GIMPs itches" should be
> > "GIMP's itches", "minimal dependencies. and a" should be "minimal
> > dependencies and a".
> 
> Fixed both.
>  
> 
> >     There should be a Requires on ImageMagick.
> > operations/common/magick-load.c has a fallback image loader which uses
> > convert(1).
> 
> Done.

Thanks, Kalev.

ACCEPTED

Comment 6 Kalev Lember 2015-03-13 16:13:35 UTC
New Package SCM Request
=======================
Package Name: gegl03
Short Description: Graph based image processing framework
Upstream URL: http://www.gegl.org/
Owners: rishi
Branches: f22
InitialCC:

Comment 7 Gwyn Ciesla 2015-03-13 18:51:12 UTC
Git done (by process-git-requests).

Comment 8 Kalev Lember 2015-03-13 19:36:57 UTC
Package imported and built.


Note You need to log in before you can comment on or make changes to this bug.