Bug 120151 - redhat-config-samba cannot use smb password containing '(''or ')'
redhat-config-samba cannot use smb password containing '(''or ')'
Status: CLOSED DUPLICATE of bug 112528
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-samba (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-06 09:17 EDT by reubendb
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description reubendb 2004-04-06 09:17:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
redhat-config-samba cannot use the password when the samba password
contains the parentheses '(' or ')'. Not sure what any other character
will cause redhat-config-samba to fail. On the console, the following
is outputed:

# redhat-config-samba 
sh: -c: line 1: syntax error near unexpected token `('
sh: -c: line 1: `/usr/bin/smbpasswd -s testuser uiui(ui'

# redhat-config-samba 
sh: -c: line 1: syntax error near unexpected token `)'
sh: -c: line 1: `/usr/bin/smbpasswd -s testuser io)io'

Version-Release number of selected component (if applicable):
redhat-config-samba-1.0.16-1

How reproducible:
Always

Steps to Reproduce:
1. run redhat-config-samba as root from console
2. Click on Preference -> Samba User -> select a user -> Edit
3. Change the password to something containing either '(' or ')'. Look
at the console and you'll see the output
    

Actual Results:  Error on the console. Samba password for the user is
NOT changed.

Expected Results:  Should not generate error, as it's a valid
password. The samba password for that user should be changed

Additional info:
Comment 3 Brent Fox 2004-06-23 18:06:24 EDT

*** This bug has been marked as a duplicate of 112528 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.