This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 120172 - Menu icons won't theme
Menu icons won't theme
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 119991 FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-04-06 12:32 EDT by Jeff Moe (jebba)
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 11:43:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Moe (jebba) 2004-04-06 12:32:18 EDT
Icons in the menu do not change when the theme is changed. This
is true even if the theme has an icon of the correct name.

The cause of this is that in
/usr/share/applications/system-config-bind.desktop
the Icon= line has the absolute path to the icon instead of just the
icon name.

Icon=/usr/share/system-config-bind/system-config-bind.png
When it should have:
Icon=system-config-bind.png

The icon should be put in the hicolor theme, per freedesktop.org.
/usr/share/icons/hicolor/48x48/apps/
Comment 1 Bryan W Clark 2004-10-04 15:17:34 EDT
ping Jason, any progress on this?
Comment 2 Bryan W Clark 2004-11-01 00:53:23 EST
appears to be fixed in current release.
Comment 3 Bryan W Clark 2004-11-01 01:04:53 EST
(In reply to comment #0)

Doh! Re-opening.

> Icon=/usr/share/system-config-bind/system-config-bind.png
> When it should have:
> Icon=system-config-bind.png

This is fixed

> The icon should be put in the hicolor theme, per freedesktop.org.
> /usr/share/icons/hicolor/48x48/apps/

However the icon is still missing when using another theme.
Comment 4 Matthias Clasen 2005-04-19 11:43:40 EDT
Appears to be fixed in Rawhide. 

Note You need to log in before you can comment on or make changes to this bug.